Showing rests in second voice

I know the Notations panel will let me globally suppress ‘coincident rests of the same duration in opposing voices’. For the most part, I’m very happy with that.

But in one 4/4 bar, I have
Voice 1: crotchet, crotchet rest, more notes
Voice 2: crotchet, rest of bar empty.

What displays in Voice 2 is crotchet and minim rest (i.e. no crotchet rest in beat 2), and that looks really odd. In that bar (only), I don’t want coincident rests suppressed - I want the crotchet rest in beat 2 to display. Start/end voice and all of that doesn’t do anything in this situation.

One way round it is to de-activate the ‘coincident rests of the same duration in opposing voices’ and then remove the ones I don’t want, but as it’s most of them, that’s going to take an age. Must be a better way that I’ve missed?

This works for me:

  • Enter the notes.
  • Select the crotchet rest, in the properties panel tick “forced duration” and “rest position”. That will display two crotchet rests, one for each voice.
  • Select the voice 2 rest and tick “End Voice Immediately”. That gets rid of the minim rest
  • Untick “rest position” so the crotchet rests are on top of each other again.

Oops, maybe I didn’t read what you wanted properly, and you only need to do the first step. But this should get you unstuck, either way.

Thanks - but I do actually want both crotchet and minim rest to display; what I get is the crotchet rest suppressed, and that makes Voice 2 look as if it’s missing a beat (the crotchet rest). :slight_smile:

That’s what I get, after the first two steps above.
forced rest.png

That’s it! (Then I put a number in the Rest position to move the rest down to be well clear of the Voice 1 crotchet rest.) Great - thanks. :slight_smile: