showing short section of chords

Hi, I’m a new Dorico user. It’s brilliant and a joy to learn. I’m having an issue with hiding certain chord symbols, I know this has been discussed a lot but I haven’t found an answer that has helped my situation yet. This is literally the first time I haven’t been able to figure something out in less than 30 seconds, which is remarkable.

I need to show chords symbols in a trombone part for a short improvised solo. Adding chord symbols to the instrument adds ALL the chord symbols for the whole piece. I realize you can Ctrl+A and filter chord symbols, and hide them. This would also select and hide the chords in the guitar part which I don’t want to do. Selecting only the chords symbols in the trombone with the marque and not the guitar chords is tricky (they’re adjacent in score order). It’s a long piece (15 minutes) and I’d have to go through it section by section, painstakingly selecting and filtering trombone chords and hiding them. I tried hiding them in the trombone part, which worked nicely, but they’re still appearing in the score. I need to hide them in score and part. I read in one of the threads on this topic the idea of a “only show chords for slash notation” option, which Daniel liked the idea of. This would be great in this situation, although I can think of other situations where it would still be difficult.

This just seems like a lot of complicated steps involving navigating all over my large score and switching layouts, just to simply add a few bars of chord symbols to an instrument. Ideally I could add these chord symbols somehow without having to leave the score and section of music I’m in, for an easy workflow. For now I’m going to leave the unwanted chord symbols in, and take them out when the piece is done and I’m no longer in the creative stage, but if anyone has any tricks, please share!

Certainly in the future we plan to add additional controls that will make it easier to specify where chord symbols should be hidden and shown in different places throughout the piece.

But in the meantime, you should find that selecting one chord symbol in the trombone part, then doing Edit > Select More repeatedly will select all the chord symbols just in the trombone part (first in the remainder of the bar, then the system, then the whole flow). Then you can use the ‘Hidden’ property in the Properties panel to hide them throughout the part. Then all you need to do is select the handful in the short solo passage where you want them to be shown and deactivate the ‘Hidden’ property to make only those ones appear.

Great solution, I will do that until the quick controls come along. Thank you!

Found a minor bug when using edit > select more with chord symbols (unless I’m missing something): sometimes (but not always) if I select a chord in the first or even 2nd system, pressing select more repeatedly will stop working after having selected all the chord symbols in the system. I will have to deselect and try another chord in the next system to select all chords in the flow.

Does it work in Galley View? Are you using the Layout Option to show chord symbols at the top of the System, rather than on individual instruments? Does the instrument whose chord symbols you’re selecting on the first system appear on the second system?

It works in galley view. I have the layout option set to show on individual instruments. The problem occurs in a part layout, so I guess this option doesn’t really have any effect, is that correct? When I change it the same thing happens. There are 5 systems in the flow in question, and they all have chord symbols. Select more only works for the entire flow if I select chords in systems 3-5, but not 1-2. Same problem occurs in the other layouts with chord symbols.

Not a big deal, but considering I only need chord symbols in the layout in question for about 8 bars of a 350 bar piece, and have to individually hide the rest of them in all 6 flows, it’s a small annoyance.

If you have a specific project that reproduces this problem, please attach it here together with steps to reproduce the problem. Thanks.

Here is the project.

-Go to the first page of the flute and tenor saxophone layout.
-Click on one of the signposted chords in staves 3, 4, or 5, and hit select more- it will only select the chords in that stave, but not the rest of the flow.
-Click on one of the chords in stave 6 and hit select more, it works as expected.
Journey to the Centre of the (917 KB)

Sorry for the delay in coming back to you on this one, and thanks for providing an example. I was able to reproduce the problem, and see what’s going wrong. We’ll fix this in a future version of the software.

Great, thanks!

The procedure I have found to be the fastest for me when dealing with one player (such as a sax part that needs chords only on 16 bars) is to use the layout for that one instrument only – and in PAGE mode. Then select ALL the material, notes, markings, everything in the regions where you want to hide the chords.

Define two shortcuts: Filter Chord Symbols (which I set to Shft+Ctrl+Alt+C) and Hide (which I set to Shft+Ctrl+Alt+H.)

When you have selected a bunch of material, simply hit those two shortcuts and it will hide all the chords in that selected range. That’s quicker than any other procedure I have seen.


I have a similar issue - I’m writing a hymn in which a descant appears for only a few measures, and then goes away (I plan to hide the staff when there’s no music happening). When the descant is active and unhidden, I want chord symbols that normally appear over the melody line to appear over the descant. I can’t for the life of me figure out how to move the chord symbols to appear only above the descant just for these few measures, and to only be above the melody the rest of the time. If I hide the chord symbols for all other measures of the descant, then I can’t hide the descant staff, which leads to a lot of wasted space. Any ideas on how to fix this? I included screenshots to show what my desired outcome is.

Perhaps it would be sufficient simply to specify, on the Players page of Layout Options, that chord symbols should always appear above the top staff in the system, rather than above specific instruments?

I must have missed the notification that you had replied, Daniel. Your solution works perfectly - thank you!