Shrinking MIDI clip leaves notes hanging off end

When I shrink a MIDI clip, I often have notes that will extend beyond the end of the newly sized clip. Is there any way to make Cubase truncate the note? Right now I have to open the key editor on every clip and drag the note-off point of every note that extends beyond the end of the clip.



I remember, there was a discussion about this in the past already. I remember, there wasn’t a clear solution.

What I’m thinking of right now would be a Macro, which you would call after you shrink the MIDI Part:

  • Transport > Locate Selection End
  • Open Key Editor
  • Edit > Split at Cursor
  • Close Key Editor

I haven’t tried though.

I’ve just started using Cubase (still on my one month demo license), so macros are just a bit too intimdating at the moment. I suppose, as a future feature, one could have some modified clip shrink that would change the note off values.

There’s a preference setting in Editing > Midi to enable the splitting of notes and/or controller messages when splitting a midi event.

Assuming that is checked for notes, then the quickest macro-free way to make the overhang go away may be to split the event in the Project Window and then delete the second event.

Ah okay. I had tried splitting the events but that had the same bad result. I’ll have to check that setting.