Signal generator - how to determine the rising tempo of frequencies depending on he time window

Hello, I have now spent some time trying with the signal generator to understand the matter of the two median frequencies, as their operation and purpose are unfortunately not described in more detail in the (online) manual.
Basically, I would like to generate the following:
A sine signal that develops as follows:
For the first ten seconds, a constant sine signal of 200 Hz should be heard, starting at -infinity (-140 dB) and arriving at the first “intermediate plateau” at -6 dB.
From then on, the level should remain at -6 dB until further notice, but the frequency should increase steadily from 200 Hz to 1000 Hz between 0’10" and 2’10" (i.e. within 2 minutes).
Exactly this step does not succeed, no matter in which of the other input fields for the frequency I enter the 1000 Hz, the frequency increase from the 200 Hz apparently proceeds according to its own laws, according to its own “speed” and goes far beyond 1000 Hz, from the defined time span the frequency then jumps down to the targeted 1000 Hz, but that is not the point of the matter.
How can I make it so that the selected rise time between 200 Hz and 1000 Hz determines how slowly or how quickly the frequency increase proceeds, and that the increase really only goes up to 1000 Hz and not beyond?
I’m pretty desperate at the moment :frowning:

The level envelope and frequency envelope should have same time points.

Thank you ,Philippe. I also had this in mind - but it leads to unwished results as described above.
In the following, simplified demo the frequency starts at 200 Hz, but rises up faster and higher than wanted and ends up at 2600 Hz(!) at 1m59s999ms, at Minute 2m00s000ms it jumps down to 1000 Hz with the following settings:




Tested versions: WaveLab 10 Pro (lastest build) + Wave Lab 8.5 Pro (latest build)

Same result with the following settings:
The signal ends at 2600 Hz instead of 1000 Hz! WHY? :flushed:



I confirm the problem but there is a solution: just click this option:

1 Like

Thank you very much, that helped! But is this “only” a workaround, so to speak, or is the somewhat unpredictable behaviour of the signal generator without setting this checkmark intentional or is it a programming error? If it was intentional, what is the purpose of this behaviour?

Actually, this should be mandatory when there the frequency is changing. I think I will remove this option in the future (and keep the setting ON).