Since switching to Cubase from FLStudio my mixes won't level

I’m running into an extremely frustrating issue where my mixes are not leveled no matter what I do. My kick is always too quiet or too loud, my high frequences fight for space, and can never get the mixes right.


I’ve never had this issue before, specifically when I was using FL Studio. My mixes were always more leveled and didn’t spend nearly as much time on the mix. It’s so frustrating because I’ve finished maybe 2 tracks this entire year, and I have a bunch of tracks unfinished because I’ve become so sick of trying to mix them down. The more I try to mix, the quieter my mixes become… and I get nowhere. I don’t know what the fuck is going on. I’m to the point where I am starting to hate music production because of this issue, and it’s becoming a chore to make tracks.


Also, I’m not sure if this helps but I’m also using ‘Nicky Romero Kickstart’ as my main sidechain. The only major switches I’ve made in terms of plugins is Kickstart and fabfilter. Also since switching, I am using a Scarlett 18i8 soundcard. I never had this much of an issue in FL studio for some reason. My kicks would be a little loud but I wouldn’t go back to my mixes and over mix.

Is there some kind of setting that I’m missing because I can’t figure this out

Bumping …

I don’t know much about FLStudio, but if I remember correctly it has a maximiser and/or multiband comp on the main out buss by default. This will obviously level things out as you mix. Cubase utilises full dynamic range which can be jumpy and sometimes needs taming.

Do you think this could be the issue?

It’s possible but whenever I turn up my Limiter (Invisible Limiter, Waves L2) the track still feels uneven even though it’s hitting the limit peak. I don’t understand how maximus would be able to tame the entire track so well.

Were you using the sounds that come bundled with FL? Aren’t they all pre-produced to sound like a record? Basically, canned sounds that are already treated so they mix together well? All you have to do is pick the sounds?

Cubase not so much.

Maximus is a whole different kettle of fish compared to L2 or Invisible. L2 and Invisible are wideband peak limiters whereas Maximus is a multiband compressor/limiter with per band saturation and a global limiter at the end.

For similar processing in Cubase you’ll need either the Cubase multiband compressor, L3 multimaximizer or L316 before going to the L2. You can probably just use either the L3 multi or L316 on its own.

With wideband limiters like L2, if the kick slams down and gets limited, the whole track dips along with it. You need to go multiband so kick and bass limiting doesn’t affect the rest of the frequency spectrum.

Appears to be on sale at the minute as well…