SINE Player Expression Mapping

I’m trying to get the Baltic Strings, which is supported by SINE Player, to work with Expression Maps in Dorico 4.0. There are two objectives. 1) Support a number of custom expression technics. That would be technics other than your typical ‘pizz’, ‘marcato’, ‘legato’ and so on. 2) Use the Expression Maps to support dynamics while using other articulations. I have managed to get key switches to work with two out-of-the-box articulations, sort of. Using ‘Basic’ I set a technic to Staccato and Legato. Basic stuff. When I play my test case, it goes from Staccato to legato to Staccato to legato. The Playing Techniques lane in the ‘Play’ shows Staccato to Legato to Legato to legato, which agrees with what I hear. So it never returns Staccato. The curious thing is the hover-over dialog on the return to Staccato show ‘Legato + Staccato’. When I return to the Legato, the hover-over dialog shows ‘Legato.’ I’ve listened to and watched every video on the face of the planet and read all the document, comments, and forum that I find and know has an answer. I must be missing something. Any suggestions?

|Processor|Intel(R) Xeon(R) E-2286G CPU @ 4.00GHz 4.01 GHz|
|Installed RAM|128 GB (128 GB usable)|
|Device ID|71366C4C-CAB0-46D9-9EB9-A3DFEC47C483|
|Product ID|00391-50000-00000-AAOEM|
|System type|64-bit operating system, x64-based processor|
|Pen and touch|Pen support|

You should update to Dorico 4.1, for starters.

We really need a sample project file to see what’s going on.

Will this work for testing?
TestProj.dorico (1.9 MB)

It never returns to staccato because you have “legato” articulation starting in bar 2. The word “legato” is directly above the tied notes in Bar 2 as well as above regular sustained notes in bars 6 and 7. You can’t expect Dorico to return to staccato like you had it in bar 1 if you keep telling it to play everything legato:
image

Also, the project shows a custom articulation “staccato + legato” - for Dorico that’s a specific, unique articulation. I don’t understand why you’re using legato written as a word instead of a slur like so:

image

It would help to export the expression map and post it along with the project. My hunch is you have a problem with how legato is programmed. Since you’re using the word instead of the slur, it appears as though Dorico is waiting for something to cancel this command. Why not use the regular slur instead?

I don’t see what you’re seeing. In bar 4, I mark the notes with staccato marking, which I would think would override the legato from bar 2. Where would I find the custom markings? Attached is the expression mapping I’m using.


SINE Baltic Strings.zip (1.4 KB)

Could you tell me what happens when you play this modified version using your current routing and expression map?

Does the staccato in bar 4 return properly?

TestProj_v1.dorico (1.9 MB)

First things first. Thank you everyone for jumping so quickly. I really appreciate it.

It plays as expected until the last not, which uses the staccato articulation. It appears from the Playing Techniques lane that there is no technique being applied to the last to note. Probably because I don’t have a Natural type included in the mapping. I guess that’s telling me that Dorico reserves the use of Legato for slurred notes. I changed the articulation to ‘detache’ and removed the slurs. I returned to the old behavior.

The first problem is solved. I created a ‘Sustains’ technique and mapped my articulation to the new technique. It seems to move from Staccato to Sustains and back as expected.

The next problem is using Expression Maps to define dynamics. The problem is Baltic Strings does not support the default dynamic marking. It has been suggested that I use Expression Mapping to create my own dynamics. I found that if I choose ‘f’ for the technique and a Control Change Action, I can set a dynamic. Using CC 11 with a value of 127, I create a louder dynamic than CC11-20. To confirm I used the ‘Audition’ button included with the Expression Mapping dialog. When I added an ‘f’ and ‘p’ to the score, I hear no change in dynamic. So the express is not syncing up with the score. How can I get two unrelated techniques to get applied simultaneously? Is there a better approach?

I’ve attached the project with the new settings.

TestProjDynamics.zip (1.9 MB)

I’m not sure that dynamics as playback techniques work. Why not just use CC1 and CC11 as the controls for dynamics in the Expression Map?

1 Like

Perhaps I am way off, but is @pkennedy using Exclusion Groups to prevent opposing techniques from interfering with each other?

1 Like
  • Sorry, but why? This makes no sense:

image

  1. In the original post, you had a legato marking applied to sustained notes. And you used the “legato” on them not as a slur that would work on the note level like a staccato, tenuto, marcato, but as a written-out word - i.e. as “direction” that requires another direction to cancel it. But there were no legato passages in that file at all and there wasn’t a new direction to cancel that direction-level legato - which is why the staccato never returned properly. In the version I sent back, I modified the tied sustain notes into standard slurred legato and removed the legato as direction.
  1. In this new file, you deleted the “Natural” technique from the map that’s typically used for regular unmarked notes and instead created a “Sustains” custom technique.
  1. In my opinion, the problem is with the logic you are using to create an expression map. It looks (and I apologize if I’m wrong here) as if you take a patch from your library and quickly think of some custom score marking for it - possibly ignoring the standard conventional markings that are already available.
  1. Perhaps a better approach would be to start from the other end - first, take the existing, standard score markings in Dorico and think of how you would assign them between the patches in this library based on what sounds best and most convincing for each specific marking or symbol. There doesn’t seem to be a dedicated patch available in Tallinn for such a common articulation as a marcato - so you’d have to decide how to handle this in case you need a marcato in your score: potentially reuse patches with modified settings, layer in SINE if possible, or rely on Dorico’s built in accent ranges. Same with accents, etc.
  1. For the patches with weird and possibly misleading marketing names, such as “Dynamic Waves tremolo/harmonics”, you might think what standard notation OT must have used in the score for players to record it and proceed from there. The regular unmarked notes (Natural technique) might sounds best with portato instead of the typical sustain patch, and with length conditions specifically tested to achieve the best sound for specific note legnths. But starting from notation that you use, rather than from the library, and then allocating patches based on what sounds best for the given score marking might be a more systematic approach than just following the patch name.

1 Like

@benwiggy, in my latest attempt at controlling the dynamics using the Expression Mapping, I used CC11. It works fine with the ‘Audition’ function in the client. It’s not being supported by score markings.

@Derrek, At this point, I’m only using the default setting where Exclusion Groups are concerned. I’ve gone through the documentation and found the implementation of the Exclusion Groups unclear. I’ll need to play with more to see if I can put the pieces together.

@ebrooks ,

Great explanation and I tolding agree with you. The reason for using Legato to begin with was I need an articulation that indicate that the sound should be sustained. I was looking Sostenuto. The only Sostenuto to be found was Sostenuto Pedal. Even that articulation is not available to insert on the score.
Great explanation, and I totally agree with you. The reason for using Legato was that I needed an articulation that indicates that the sound should be sustained, not slurred. It seems that Dorico reserves Legato for slurred notes. I was looking at Sostenuto. The only Sostenuto to be found was Sostenuto Pedal. Even that articulation is not available to insert on the score. This is why I created ‘Sustains.’ Most of the other Baltic expressions I could mostly apply to existing articulation types. I’ll revisit my strategy and see if I can stay within the standard articulation.

Have you set every one of your articulations in the expression map to use CC11 as the dynamic control?

That’s what I’m currently doing, and it seems to work within the Expression Mapping Client. It doesn’t want to work in the score when I use it in combination with another articulation. So if I have a staccato section that is loud and goes soft, Dorico won’t apply both the dynamic and staccato simultaneously. It has a singular focus.

Perhaps any regular, unmarked note of some duration (e.g. quater and longer?) could be reasonably expected to result in plain sustain sound. That would mean programming “Natural” technique in the x-map to trigger the sustain patch from the library.

If memory serves, the Kontakt versions of OT libraries use CC1 for dynamics and reserve CC11 for overall patch volume. If that’s also the case with SINE (I don’t know), this might explain why you’re not getting the playback.

Each articulation in the map has fields for dynamics in order to play them at the requested volume. I only use Berlin Percussion now - but IIRC in the Kontakt versions of OT libraries, the short articulations like staccato are triggered by velocity, not a CC. Perhaps it’s a good idea to check in the manual what triggers are used in SINE for Tallinn. You need to use the same trigger for dynamics that the library comes with.

Just in case - the way you program dynamics in the Expression Map is like so: highlight the articulation on the left and then choose the trigger method on the right, as shown in the circle - velocity or the particular CC that the library uses. The screenshort is for HSO, which seems to be using CC1 for everything.

Worked perfectly. SINE uses CC11. Added it to the Volume dynamic, and dynamic started to happen.

I tried to add the Sustains key switch to Natural. C0 is the switch. When Natural kicks in, it sounds a low C. Not quite what I was looking for.

Thanks again for all your help. A truly educational experience.