Single Bar Rests Width


I can’t seem to find a way to change the width of single bar rests… I’ve tried the engraving options under ‘‘rests’’ and the ‘‘note spacing’’ in Engraving mode. I find they take up too much space… have I missed an option? (I know in that case there isn’t much on the system but it would still be an handy feature)

Thank you in advance!

Where a Tempo or System Text item coincides with a multirest, the multirest is lengthened to be at least as wide as the text above.

I don’t know what the solution is but I’m sure if you search the forum for multirest tempo you’ll find plenty.

I see… I didn’t know it was the tempo’s fault… (Still it is longer then the text…) I hope one day we will be able to manually adjust it.
Thank you for your answer.

If somebody else is interested, it seems it’s a feature, read here:
https://www.steinberg.net/forums/viewtopic.php?f=246&t=122708&p=665965&hilit=multirest+tempo#p665965

Wacky workaround:

Directly under the tempo, invoke the Shift-X popover and enter a single space (using spacebar!). Then hit Enter.

The bar will no longer act like a multirest, because it has something in it. Of course this’ll also force the stave to show in the score, if it’s currently a hidden stave.

You can adjust the width of bars individually by using the note spacing tool in Engrave mode. Select the blue square that appears above the barline, and nudge it with option+arrow (mac) / alt+arrow (windows). Add cmd / ctrl for larger increments.

For what it’s worth, we do intend to refine this behaviour: it is designed such that a multi-bar rest followed by another multi-bar rest, which will typically have some kind of system item like a rehearsal mark or tempo above it, will be sufficiently wide that the system items won’t collide, but it doesn’t need to do this if there is no multi-bar rest following the first one.

Andgie, this basically doesn’t work when multirests have system text or tempo objects above. Trust me, I’ve tried!

One can force more bars onto the system by using a system break that waits for another system break, but even then the Note Spacing tweaking is made harder by the fact that Dorico really really tried hard to keep the multirest longer than the tempo object.

Leo,
I didn’t realize the tempo text made such a difference, thanks for correcting me :slight_smile: