Single Midi note not sending data

I am using Cubase 5 to send midi to Vienna MIR se. It is mostly working fine, but in one part, Clarinet, there is a single note that is not sending midi on playback. Notes to either side are sounding, just not that one. When I touch the note in the key editor it sounds and sends midi, but when I press the key on the keyboard in the editor, it does not sound or send midi to MIR, nor in playback. All a bit strange…

I can only presume that the midi note (D2 in cubase) is assigned to a keyswitch or something, but I cannot see it and have checked over and over again.

Any ideas on how I can check this - it is very frustrating.

The other thing besides a keyswitch, is a key split. Do you have it loaded as a multi?

Thanks for the quick reply.

No it is not a multi. Each instrument is assigned to its own midi channel and sent via internal midi to MIR. Everything is set up correctly, and the note that is not sounding has notes either side of it which do sound on playback.

It has me stumped at the moment - but it is bound to be something simple in the end - just a matter of finding it!

I don’t have MIR so I have no way to check that side of the configuration. The Cubase side would be things like

Do you have input transformer or other MIDI filter type plugin on the track?
Do you have a Generic Remote or external Device that is stealing the keystroke?

There is no external controller in use at the moment, and I can’t see any keyswitches which may be interfering.

My workaround for this problem was to create another midi track and move the midi across - problem solved. I do hate mysteries unsolved though.

Thanks for your help jmcecil - much appreciated.

Aloha Basso and thanks for bringing up this topic.

Your work-a-round is effective and simple but still I see the mystery lingers still.

Is the problem track a MIDI or Instrument track?

I ask because this happen to me more often when using Instrument tracks than MIDI tracks.
Why? Dunno.

I have gone as far as to remove all MIDI info from a track
(notes and controller info) and just leave the offending note and still the prob persists.

Which lead me to believe that the problem may be some sort of corruption
in the programme’s creation of the track in the first place.

Why else would the creation of another track clear up the prob?
{’_’}

The track was a Midi Track. A bit of a mystery why it was happening - that note worked on all the other instruments which can play that note too…