Skipping playback, audio dropouts

I am on Version 5.1.32.2114 (Apr 18 2024), Dorico 5 AudioEngine Version 5.6.40.119.

After updating to the latest version, I have started encountering a very bad problem, which is that playback is skipping constantly. Audio also drops out when I place down notes. I’m noticing this both in new projects and older projects I open up. I can confirm that this happens both when using NotePerformer and the default playback template.

I should mention that when this playback skipping/dropout issue happens, the playhead sometimes gets stuck and starts jumping back and forth. This only seems to happen with NotePerformer.

This did not use to happen before. I have also checked with other applications, such as MuseScore Studio and Reaper, and this audio dropout issue does not happen at all with them (or my system audio). This might be unrelated, but Dorico also now causes my computer fans to start spinning louder as soon as it opens; this didn’t use to be the case either.

I am on Windows 11, and again, I have not experienced any of these issues before.

I think it would create a diagnostics file from within dorico and upload it here so the developers can have a look.

Good point. Attaching diagnostics file from one of the projects now.

Dorico Diagnostics.zip (810.0 KB)

I don’t see anything that leaps out at me in your diagnostics, Fredrik. My colleague @Ulf may perhaps have a better idea what might be going on, but everything seems to be in order.

You could try disabling ASIO Guard in the Advanced Options section of the Play page of Preferences – you’ll need to restart Dorico after you do so. Does that make any difference?

You could also try a different buffer size value in Edit > Device Setup to see if that helps; if you’re experiencing drop-outs, you could try the next largest buffer size.

Weirdly enough, setting the buffer size to 1024 did help - but this is not something I have ever had to do before, and I have been using Dorico since version 2. This is a completely new issue that was only introduced after I upgraded to the latest version of Dorico.

Disabling the ASIO Guard didn’t help.

Nothing else on my system requires me to increase the buffer size; only Dorico does, and only recently.

Surely there has to be a problem here? I can take a video of what is going on; it’s not just playback, but the playhead itself gets stuck and jumps back several times.

If you were previously reasonably up-to-date before you updated to Dorico 5.1.32, there’s very likely been no change in any of the audio components that Dorico relies upon. We’ve been using the same version of the audio engine, for example, since Dorico 5.1.10, which was released in January 2024. The new Steinberg ASIO driver has I believe been updated once since then, but you’re not using it.

I believe it’s more likely that a change in a configuration on your system, e.g. perhaps in the device drivers for your MOTU interface, is responsible for the change in behaviour.

I have not updated my MOTU drivers since I bought the interface and it’s been 100% fine. I also noticed now that even having 1024 as buffer size doesn’t stop this issue; I am still getting dropouts, and it’s making Dorico unusable. Again - no other audio apps (MuseScore Studio, Reaper, Cubase) have this issue. It is only Dorico.

UPDATE: I do not know how this fixed it, but I restarted the computer two times and now the problem has vanished. I don’t know why, but I’m not gonna look a gift horse in the mouth. Problem solved, I think!

Hi Frederik, should the problem return, please come back here. There are at least 2 more things to have a closer look at.
But I hope that you don’t need to and that it stays fine now.