SL8 treatment results in double speed playback

I had a sample rate mismatch between Cubase 96K project and my audio device 48K. Mixdowns were playing at double speed. I thought I fixed this by changing the project to 48K and changing all the files to 48K. Mixdowns (without SL8) now played correctly at 48K.

However, when I apply SL8 to selected events, those events continue to play at double speed, while the rest of the song plays correctly.

Any help please?

Can you post a screenshot of the SL project within Cubase ?

I’m trying to get a screen shot to you. Most recently, when I apply the SL8 extension to an event originally recorded during the mismatch, nothing appears in the editing window and the sound is muted. If I make a new recording in the same project without the mismatch, SL8 works as expected. When I go into Cubase pool, I see that all the originally recorded files are listed as 96K, and if I convert one of these files to 48K and play back the raw file in the pool, it plays back at double speed. So changing all the files to 48K doesn’t seem like a viable option.