Slate Digital FG-X

Anyone getting this plug to show up in W7? It shows up in N5and C6 both 32 and 64 bit versions but no joy so far in Wavelab. Any suggestions, thanks and take care Logan

It shows up just fine for me under VST/Slate. I’m not sure why it won’t for you. Did Wavelab (I assume Wavelab 7) do a scan for plugins when you started it up after installing FG-X?

yep W7. Well it seems to look for plugins, what folder do you have the plug in, did you follow the advice of putting it in it’s own folder? I’ve tried it both ways. Take care Logan

Mine is just in C:\Program Files (x86)\Steinberg\VstPlugins with all the rest, not in a folder on its own, and it shows up and works fine. I did need to force a plugin detection (in Options->VST Plug-in settings…) for it to show up, but then it did!

Thanks man I’ve forced plugin detection 3 or 4 times now and still no luck. I’m going to uninstall again and try to reinstall everything and see if that helps. When I installed the plug at first I believe it said that it would install the 64 bit version of the dll in the x86 and then when I clicked that it said it would install the 32 bit dll in the non x86 vst folder. That got it to show up in Nuendo and cubase 32 bit vers, but I just got an email from support at Slate and they say there’s no 64 version of the plug, so obviously I either misread or misunderstood the installation, so I’ll do it again and pay strict attention. take care Logan


After rendering a file , going back to the original file to adjust something , the FG-X gui is frozen . The plug still works as I can hear the changes.
Also WaveLab 7 (win XP - SP3) doesn’t remember the last session after closing.
Sometimes I also get the warning :" A serious error…etc. "

Any help appreciated.


Well part of the problem I was having was because when you install the plug it asks where you want to put the 64 bit dll and same for the 32 bit dll. But according to support from Slate the plug is not 64 bit. I uninstalled again and only checked the 32 bit dll to be installed and it appeared after forcing Wavelab to look for plugs. It seems to be working fine now. Paul there is something on the Slate forum about problems with wavelab, but I seem to be OK so perhaps the problems are with Wavelab on XP, I’m on Win7. Take care Logan