Slate plugins and 8.0.2

Anyone having trouble with Slate VBC and Cubase 8.0.2? I’m working on a project that I started in 8.0.1 and I’ve got a Slate VBC on the master bus. Several times now the plugin has just died. It cuts all the signal on my Stereo Out and I have to remove the plugin. I can then re add the plugin and it works fine again, but sometimes only for a while.

Just happened again while I was typing my post above! lol

I had major issues with VMR on windows 7.Moved to 8.1 and it works ok.Most slate plugs take a while to load though for some reason.They all seem to work ok at the min but I wouldnt trust em on a big session right now.My computer is quiet old though so Im updating soon and hoping these issues go away.

Check updates.

There are some recent releases:

Virtual Mix Rack -
Virtual Bus Compressor -


I just installed the new VBC update this afternoon but I’m still having the same issue. Hopefully it’s just confined to this one project. I haven’t tested any others yet.

VBC Red doesn’t work in my set up if I try to use it on its own. It bombs out Cubase and then Cubase black lists it. It also bombs out SoundForge. At first I was going to report the problem to Slate but I couldn’t find anyone else with the same problem. Funny thing is it works fine in the rack, it’s only when I load it as a single plug-in, so if I want to use the Red on its own I have to load the whole rack and bypass the others.

I have no idea why this is but honestly, I can’t be arsed with it. I wont be buying any more Slate plug-ins. I paid good money for VCC but to use vr 2 I have to load the rack as well with just VCC in it, even though I don’t own, or want, the VMR collection. I find this pretty lame so I’ve started using Satson instead.


Slate plugins have been totally unstable for me in every version of Cubase. Either the vst version works but the vst3 doesnt/vice versa, plugins break when loading from a saved sessions, causing the DAW to crash on closing, etc. They sound great but are unusably unstable.

[Windows 7 x64 here] I just opened a 8.0.1 project here and dropped VBC (all 4 plugins, v1.2.5.9, vst 2) in master bus. Seems to be working fine.

Just an update… Strangely enough, I’m no longer having the problem. It was happening frequently in my current project when I worked on it at the weekend but now seems to have solved itself. I’d re-saved the project a couple of times in 8.0.2 so maybe that somehow cured the issue.