Slow file

I’m having a problem with this file (attached).
Ch 3 NEW.dorico (1.1 MB)

Every operation takes 10 times longer than it should. Painfully slow and unusable.

Anyone else finding the same thing?

It seems OK for me.
After using Select All in each flow, I tried various things like: add a sharp (to all the notes selected in that flow), move up/down diatonically, chromatically, by an octave, lengthen/shorten notes, move notes left/right. All operations were as quick as I would expect.

Huh. Must be my machine, but it’s doing just fine with all other files. Thanks.

Diagnostics here.
Dorico Diagnostics.zip (1.6 MB)

It also worked fine for me. I tried filtering notes, adding new bass clef notes at the beginning and a few others but all operations went quickly and smoothly.

Yes, no problems here either. I can see from the application logs in the diagnostics that some operations in Engrave mode were taking around a quarter of a second to complete, but otherwise it looked reasonable to me. If you quit and restart Dorico, does it make any difference?

No, I also tried restarting my computer for good measure. That particular file still crawls for me.

When I selected and bulk-deleted all the graphics slices, that seemed to speed it up a bit. Then I selected and deleted all the flows except the last one. At that point it seemed to be back to normal. I just find it strange that the file works fine for everyone else, and my computer handles other projects normally.

I’ve resorted to splitting the file into several smaller ones, so I’m not stuck.

Almost 5 minutes to do whatever you were doing here seems pretty extreme:

Any sort of editing seems fast for me though. Is the file saved locally on a physical hard drive? Or on the cloud? (Or automatically backed up on the cloud?) Just wondering if that could be a factor too.

Nothing out of the ordinary. Saved to a local drive and backed up to dropbox, but that’s how it’s always been.

Does anything at all change speedwise, better or worse, if you work with your wifi disconnected? Probably not, but can’t hurt to check if you haven’t already.

That’s the strange thing. Open a different file and it’s fine. No other changes.