Slowdown after Switching to Spectrum Editor

I noticed this issue shortly after upgrading to Wavelab 8, but I’ve been trying to work around it until now.

Windows 7
Wavelab 8.0.2
Waveform Editor
VST Audio Connections > Windows MME (Changed this on PG’s advice after upgrading due to lockups)
2+ hour .wav files.

When I switch to Spectrum Editor (not Spectrum View) for the first time after opening Wavelab 8, the program speed immediately reduces until I close and reopen the program. For example, I’ll notice some click or pop that could use specific-frequency-range dampening and I’ll pop over to Spectrum Editor to fix it. Then I’ll switch back to Waveform view and continue editing. From that point on, normal tasks such as highlighting waveforms and replacing selection with room tone take noticeably longer than they did prior to the first use of Spectrum Editor. I speculate that perhaps switching to the Spectrum Editor loads some resource-heavy function or bug that remains after switching back out of Spectrum Editor. The only way to cure the slowdown is closing and reopening Wavelab.

My workaround has been to avoid using Spectrum Editor altogether unless I absolutely have to, and then after using it, saving, closing and reopening the program. But this is not an adequate solution. Please advise.

Never seen that. How much RAM ? Using Windows 32 or 64 bit? Using WaveLab 32 or 64 bit?
How long is the wave you switched to, in Spectrum view?

Windows 64 Bit.
Wavelab 64 Bit.

How long is the wave you switched to, in Spectrum view?

I’m not quite sure what you mean.

I mean, was it a big file? Is it the same problem with a small file?

All the files I edit are over two hours. I’ll test with a short file and get back with you.

Btw, this is Spectrum Editor that causes this, not Spectrum View. I don’t even need to execute any tasks in Spectrum Editor. I just need to switch into it and back out of it.

I tried it on a 1 minute file and on a 10 minute file. The slowdown happens with the shorter files too, although not as bad. I should also note that I’m nearly always playing the file while editing in case you want to try replicating the issue. (The slowdown might not be as dramatic when the file is stopped.)

Also, btw, these files are stored on my main hard drive, the same drive that has my copy of Windows and Wavelab.

I still can’t reproduce. Are you sure the Spectrum editor is only concerned? (not the Spectrum view).

Absolutely positive. I wish I could screencast, but it’s too resource intensive to get a good frame rate.

Where you notice the slowdown is when you’re in waveform view, the file is playing, auto-scroll is turned off, and you’re manually scrolling with the mouse and highlighting regions. The dragging of the highlight is annoyingly sluggish. Try it on a mono file longer than 2 hours.

Strictly no speed difference here…
I am wondering what the cause could be…

Me too.

Any luck figuring this out?

I promise I’m not imagining it or making it up. I upgraded to 16GBs of ram and it still is happening. I don’t believe I had this issue in Wavelab 7.

Following up on this.

Sorry to sound like a broken record, but I’m still having this issue, and it is driving me CRAZY. I understand PG is busy with other issues, so I don’t blame him for not answering; but is there anyone else at Steinberg who would like to take a crack at this? Or fellow Wavelab users?

I will ask someone at Steinberg to try reproducing.

Did you ever find someone who could replicate this? The difference is subtle but incrementally-time-sucking for power-users.

No, I could never see it. Upcoming WaveLab version will have updated versions of underlying software modules, and this could fix your problem.

Hello Tony,

Did you ever try uninstalling the software and reinstalling again? Did you install the program in the default folder or a custom one?

Clayton, I did try this. Default folder.