Slur, tuplet and cross-staff notes

Short of manual labour, is there any way to improve this:

Screenshot 21

Ideally, I’d like the slur to be not so wild, and inside the tuplet bracket.

As a starting point, turn off collision avoidance for the slur. Either locally from the properties panel or globally from Engraving Options > Slurs > Avoiding Collisions > Cross-staff slurs.

Ah, lovely. That actually works well.

What happens if you turn off collision avoidance globally when entering certain slurs and then turn it on again later? Does it re-evaluate the slurs already entered?

Yep. The safe way to do this is to turn on the collision avoidance property and untick the tickbox. This is why, in so many cases, there’s a switch and a tickbox - the switch means “ignore the global setting” and the tickbox locally specifies yes/no (or on/off or whatever).

There’s also an interesting option in Layout options>Note Spacing> Optical spacing. It makes the space between stems even (which could be nice between the c and e).

1 Like