Small bug in Project Info dialog

Hello,

  • Open the Project Info Dialog and select Project from the list on the left side -> the Apply button is disabled.


  • Change the title -> the Apply button is enabled.


  • Press the Apply button -> the Apply button is disabled.


  • Change the title -> the Apply button stays disabled. You can try changing something else but the button stays disabled.

If you select a flow instead, the button works as expected.

Yes, this has been reported previously. https://www.steinberg.net/forums/viewtopic.php?f=246&t=173070&p=923937&hilit=Apply#p923937

Another small bug in Project Info is that no information gets recorded if I:

  1. enter text for any category in Flow1
  2. press apply
  3. enter more text in any category in Flow1 (the apply button stays greyed out)
  4. to get the Apply button to light up, enter text in Flow2
  5. press Apply
  6. the text from step 3 is missing in Flow1 but saved in Flow2

In Layout Options, one can perform many steps in multiple tabs, and then press apply, and all steps get applied. This is why the Project Info issue seems like a bug.

I am working on a large workbook where I often need to keep adding info to Flows in Project Info. The only way to avoid losing info is to close the Project Info box every time I press Apply.

Yep, I’ve reported this one too.

This problem was fixed in Dorico 3.1. Please make sure you have updated to the latest available version.

Daniel, I’ve just been working on a 99 flow project in 3.1. This particular issue certainly isn’t fixed.

It certainly is. I was the person who fixed it, and I just tried it again to make sure. The problem was that after clicking ‘Apply’, the selection in the flows list was lost, so the dialog was in a peculiar state where the fields on the right-hand side were not properly connected to the right flow. You will notice now that the flow remains selected after you click ‘Apply’, and that making further changes in any of the fields in the dialog do correctly enable the ‘Apply’ button, and changes are duly applied when you click ‘Apply’.

That’s really really not fixed. I experienced it on Wednesday a few times.

Well, you, of all people, should know what to do about that.

If I could make it reproducible I’d give you steps. I’ll email you the project. Are diagnostics useful?

Nope, reproducible steps are all that’s needed. I know you (have to) work fast, but next time it happens, try to take a breath and see if you can figure out the steps that led to the problem.

I’ve just emailed a project, a link to an unlisted Youtube video, and some written steps.

For anyone following this, the problem in the first post was fixed in 3.1, but the variation listed in the third post hadn’t yet been fixed. It’s now been fixed internally but may not make it into any public release for some time.