Smooth Waveform Drawing : graphical and performance issues in Lower Zone Editor

Hi,

With Cubase 12, a new feature has been introduced, called Smooth Waveform Drawing.
It is basically an anti-aliasing that is applied to the waveform edges to make it look smoother.
It is enabled by toggling Interpolate Audio Waveforms under Preferences.

Unfortunately, it did not come without a few issues.


Step 0 :

  • Go in Preferences > Event Display > Audio and enable Interpolate Audio Waveforms.
  • Set the Lower Zone Editor Display Mode to Show Clips and Events. editor_display_options
  • The Editor can have any tab active except VariAudio. The bug won’t occur if the VariAudio tab is opened.
  • Switch back to the MixConsole tab so the Editor isn’t displayed.

Smooth Waveform Drawing causes graphical and performance issues in the Lower Zone Audio Editor

  • Have a rather long Audio Event and split it in two or more events with the Split Tool.
  • Double-click on one of the events to display it in the Lower Zone Editor.
  • In the Editor, notice the waveform has lost its smooth state. (Note that the waveform may eventually seem smooth in first place but if you proceed through the zooming step below, it will be pixelated. Alternatively you can select another event and the waveform should become pixelated right away)
  • Zoom anywhere in the trimmed (grayed out) parts with Ctrl+Wheel, or with the Zoom slider, or by clicking the Ruler and dragging up or down.
  • Result : The Editor refreshes at a very low frame-rate.

  • Now (still in the Editor) click anywhere on the waveform with the Selection Range tool.
  • Result : The waveform becomes smooth again, and there is no performance issue when zooming over the trimmed parts.

  • Now (still in the Editor) select a part of the waveform with the Selection Range tool.
  • Click outside of the selection but keep holding the click (without moving your mouse).
  • Result : The part that was selected loses its smooth state as long as you hold the click, and will turn back smooth when you release it.

  • Now in the project window, select another Audio Event.
  • Result : The waveform in the Editor loses its smooth state again.

  • Now in the Editor, while the waveform is pixelated, select a part of the waveform with the Selection Range tool, but while doing so, keep holding the click.
  • Result : The waveform under the pointer turns back smooth as long as you hold the click during the selection, and stays smooth even if you go backwards. When you release the click, the whole waveform will turn back smooth.

  • Now start from a point where the waveform is smooth and the bug not occurring. Should already be the case if you follow the steps properly.
  • Grab the Lower Zone separator and slowly resize it.
  • Result : The waveform rapidly switches between smooth and pixelated state, and when you’re done resizing the Editor, the waveform won’t be in the smooth state anymore. (Note that the waveform may eventually seem smooth when you’re done resizing the window but if you proceed through the first zooming step, the bug will still be active and the waveform will turn pixelated)

Additional experiment 1 :

  • Start from a point where the bug is occurring (pixelated waveform).
  • Set the Clip Display Mode to Show All Clips. clip_display_mode
  • Select all the Event on the track (two or more).
  • Zoom anywhere with Ctrl+Wheel, or with the Zoom slider, or by clicking the Ruler and dragging up or down.
  • Result : Enjoy the extreme stuttering. Click anywhere on the waveform to stop the bug and the performance will back to normal.

Additional experiment 2 :

  • Disable Interpolate Audio Waveforms.
  • Notice the waveforms are no longer smooth but that’s normal since it is disabled.
  • Select the Event you previously trimmed to display it in the Lower zone Editor.
  • Zoom anywhere in the trimmed parts with Ctrl+Wheel, or with the Zoom slider, or by clicking the Ruler and dragging up or down.
  • Result : There is no performance issue when zooming over the trimmed parts, even though the waveform is pixelated.

Summary :

The new Smooth Waveform Drawing isn’t stable in the Lower Zone Audio Editor.

Under certain circumstances, the displayed waveform can temporarily revert to a pixelated state, and when it is stuck in that particular state, after selecting another Audio Event or resizing the Lower Zone for example, zooming over trimmed parts of the Audio Event produces severe frame-rate drops.

The issue does not occur in the external Editor. It is only related to the Lower Zone Editor.

Additionally when the Editor is in the glitched state, and when what is displayed in the Editor is only a trimmed part of the waveform, the graphical performance of the whole DAW is getting impacted, as demonstrated by the following video. Actually, the more trimmed part is displayed and the more you zoom in and the larger it is beyond the screen limits, the worse the performance will be :


Silence lines are thicker :

  • Select some audio with the Range Selection tool.
  • Make it a Silence with Audio > Processing > Silence.
  • Toggle Interpolate Audio Waveforms and compare.
  • Result : The silence is displayed thicker when it is enabled.

A fix for this one is planned for 12.0.30, but I’m still posting it here, so all the issues related to Smooth Waveform Drawing are gathered in a single place.


MAC users cannot disable it :

This may or may not be an issue, please MAC users, confirm if this is true or not

  • Disable Interpolate Audio Waveforms.
  • Result : The waveforms are still displayed smooth and silence lines are thicker.
1 Like

Hey,

thank you for your work.
on my macbook disabling and enabling interpolated audio waveform does make a difference.
it was off when i first started the experiment, and now that i have the box ticked it is smoother. i can clearly see a difference. however, i do not experience lower framerates when zooming.

as i stated before, the video shows an unnatural drop in frames due to youtube conversion.

let me know if that helps

The framerate drop is not caused by YouTube but by Cubase itself ! On the video we can see your pointer moving smoothly for a brief moment while in the background the editor window is still refreshing at 3 fps when you are zooming out.

Can you eventually double check the experiment ?

Edit : Added some additional information and removed the link to the video (first 10 seconds) because the Editor was in the VariAudio tab which is the only place in the editor where the issue does not occur, don’t ask me why, and the user repeatedly pressed G to zoom out, which explains the heavy “stutter”.

i can confirm ticking and unticking the option “interpolate waveform” does not do anything, waveforms seem like they are interpolated all the time on macos.

None of the issues have been fixed in 12.0.30.

Added additional information and a short video showing why this must be fixed as soon as possible.

The performance drop also occurs when multiple Events are selected and displayed in the Lower Zone Editor with the display settings Show Clips and Events and Show All Clips enabled.
Whenever you do the slightest Edit, like manipulating events with the trim, fade or gain handles, is enough to cause the DAW to refresh at 2 FPS. Just that.

subscribing. everywhere on the internet where people talk about Cubase 12 people are reporting the variaudio note blocks going missing, and most of them are not able to resolve it.

@Louis_R do you know of a workaround that can bring the note segments back for VariAudio users?

EDIT: Is it to disable Preferences > Event Display > Audio and enable Interpolate Audio Waveforms? (I don’t have the issue personally, so can’t repro/confirm.)

I think you have posted on the wrong topic, but there is no exact workaround that I am aware of for the VariAudio missing segments issue because of its unreliable nature. You can still try the workarounds that were given on the appropriate topic, but they are just temporary fixes, you click somewhere else and the issue goes in again.

While we’re at it, are you able to confirm any of the issues related to Smooth Waveform Drawing ?
If you are on Mac, the first one may not happen, but it would be great to have confirmation.
Thank you !

I found this thread from the thread you linked above: VariAudio: no bars, no notes - #36 by Louis_R

Really hoping Steinberg figures this out soon; I’m sure it’s infuriating trying to finish a project but your most important tool won’t work like it used to.

Update :

The performance issue when zooming over trimmed parts only occurs when HiDPI is Disabled.
When HiDPI is Enabled, this specific part of the issue doesn’t trigger anymore, and furthermore, it seems like the waveform stays in the interpolated state (smooth), so the first few parts of the first post become irrelevant.

However, even if HiDPI is Enabled and the waveform seem to stay smooth, the performance issue that is triggered by selecting and displaying multiple Events at once in the Editor and editing them in the project window, will keep occurring, regardless of the HiDPI setting.

In any case, any testing that you may undertake must first be done with HiDPI Disabled, which was the current setting at the time my first post was written and the videos recorded.


Here are some videos showing the issue.
Everything is still explained in the first post.

(Videos without Interpolate are below, so you can compare)


Interpolate = ENABLED :




Interpolate = DISABLED :

All of the three issues have been fixed with the 12.0.40 maintenance update.

That’s one of the biggest improvements from this update as it could impact performance and usability really badly.

1 Like