Snap Live Input Not Working Cubase 11 Pro

Hi Guys,

My “Snap Live Input” on the midi editor has stopped working and I’m not sure if I’ve done something wrong or if it’s Cubase. It doesn’t follow scales or chords.

Anyone else have this problem?

Can someone please tell me how this should be set up or should it just work? Also, it works in the Arrangement “Inspector” panel just fine?

If I should reinstall Cubase is there a best way to do it so its a completely fresh install?

Thanks in advance.

Anyone or should I post on another section?

I have this issue too. Hasn’t worked at all for me.

Crazy that such a big update would be buggy. I was hoping I was doing something wrong.

I found the fix. Click Step Input button then play a few notes on your MIDI keyboard, then click the same button to disable Step Input (see attached screen shot) . Maybe this somehow forces a refresh to recognize the snap live input feature. I’m not sure why this fixes it or how long it will last, but so far so good! :sunglasses:

Did not work for me either.
I played a bit with it, thats what I found out:

  • the workaround above is not really the workaround (enable step control), but: if you hit step control, the midi note editor window itself gets armed (midi part must exist otherwise you do not see anything in the midi editor):
    i.e. on the left top corner of the midi editor there is a record symbol. When this is enabled, live input scaling works. (enabling step control too arms the midi editor record symbol). This is covered in the manual.
  • however, now the really weird thing: I have two transport bars: on the top and on the bottom of the screen. ONLY if I hit record on the bottom transport bar, then recorded notes are scaled. If the top transport bar is used for recording, it does not (focus is lost for the midi editor window as such disarming it)
  • same goes for the display of notes during recording:
    when using the two transport bars for recording, it will either display the recorded notes immediately during recording, or only afterwards

It is astonishing how much weirdness can be put into such feature.
The transport bars doing different things here is very strange and annoying.

I can confirm “Record in editor” mode fixes it - just turn it on.

As for Transport bar issues. It works fine with a nanoKontrol2 if its any interest? Lod’s of buttons and sliders to assign key commands to and it has a full transport bar section. Also pretty cheap (depending on your situation of course). A great time saver!

Now, any ideas on how to keep “Record in editor” mode permanently active?

it will activate again once you focus the key editor window imo
So you have to keep focused the correct window (key editor) essentially when the function shall be active.

Yes the asterisk “*” which is kc for record also does not change focus

Thanks bud.