Snap Selection to Zero-Crossing only works when wave is sloping upwards

When using the “Snap Selection to Zero-Crossing” option in Wavelab 12, it only snaps to zero points if the wave is sloping upwards, i.e. when the waveform goes from below the zero line to above it. The selection should snap to the closest zero point regardless of the slope, or there should at least be an option to enable this. Right now, on average the selected zero-crossing is in the wrong place 50% of the time and I need to adjust it manually.

True. This was done to favour cycle selection (1st picture vs 2nd picture). But it’s true that might not be the best choice. I will reconsider this.

Great, thank you. If I am selecting audio in the middle of a wave I also usually select a full cycle, but half the time that cycle starts with a downward slope, causing the markers to jump to boundaries further outward to the next upward slope.

The current implementation, however, reduces the potential clicking when looping a range set on zero crossing (because the range edges have the same slope direction).

1 Like

Right, I meant the boundaries would jump to upward sloping boundaries on both sides, even in the cases when I want to select two downward sloping zero crossings that complete a full cycle.

But I also often do a lot of mini fade-ins and fade-outs at the beginnings and ends of samples, so even not when selecting full cycles within a wave file the zero crossing point will often jump to an upward sloping zero crossing when I want it to go to a downward sloping one.

1 Like

This option will be present in WaveLab 12.0.20. Actually, this option existed until WaveLab 6, but was removed for no good reason.

3 Likes