Soft eLicenser is red and i cant fix it

Hi, ive been trying to fix the soft eLicenser since last year, but even tho i tried everything, its still red. I called the Turkey distributor, but it didnt help either. Also, the only email adress i could find was for american support, which they said they would redirect the problem to our distributor, but no response :confused: Pls help i gotta do some music i dont have much time left and im frustrated.

Hi and welcome,

What does the Soft-eLicenser say? Why is it red?

You can try 2 options:

  • If you are on Windows, start the eLCC application as Administrator. Trigger Maintenance. Does it help? If not, try following…
  • Instal eLCC Helper to generate a new Soft-eLicenser Number. Reactive the licenses from your old Soft-eLicenser to the new one.

Nah man, i tried both but it doesnt work. It just says the same thing. Only thing i havent tried yet is reinstalling windows, which im not sure if it would solve the problem, but at least it will show up as a new device to the elicenser. Maybe :confused:


I’m quite sure, Windows reinstallation would solve the issue.

Unfortunately we still don’t know the exact message, eLCC is showing to you.