soft licence not working

I just downloaded cubase for a 30 day trail. when I try to activate using the activation code provided, the elicencer control center gives a elicence but when I try to regester it, a window appears telling me that there is no usd licencer attached to my computer. I can see a soft licence icon to the left in the window but I cannot select it.
I have tried everything I can think of to correct the situation, I even tried to reactivate with a new registration number, but to get a new code I must first register the original code, The elicencer controle center will not allow me to register the original code. Im stuck

The page where you downloaded it from explicitly states that an USB-eLicenser dongle is required to use the trial version:

This is required because the trial version is exactly the same as the full version, there are absolutely no limitations.

The trial period only starts counting down once you successfully activate your trial license,.

trail cubase el 9.5 30 activation code trail