Software Licensing for The Grand 3?

I have upgraded to Cubase 12, which is to great advantage to me as I can now easily work on a project at my office and at my home studio. However, any piece I’ve composed that uses The Grand 3 requires that I bring my dongle back and forth with me.

Is there any plan to change the licensing model for The Grand, or should I start looking for a different piano emulator?

Steinberg Licensing is now available for The Grand 3 if you update to 3.3.0 and claim your upgrade voucher:
Steinberg Licensing now available for The Grand 3.30

@Florian_Haack

Does this announcement mean those who have The Grand 3 as part of the Absolute bundle will also receive licence ‘update’ vouchers ?

Will the new version 3.3.0 also run using an existing The Grand elicencer ?

FWIW nothing showing as yet in my account

Unfortunately, not yet. But, we are constantly working on the migration of the instruments and of course also the whole Absolute Collection. It is still work in progress and will take more time because we really have to take care of a lot of instruments and expansions to bring all these to Steinberg Licensing.

1 Like

ok - I’m still not clear which question you are saying to.

will 3,3,0 run using an existing absolute/the grand elicencer ?

It’s fully compatible with the eLicenser version of the license. The same applies to the other Steinberg VST plug-ins that were updated to support Steinberg Licensing.

1 Like

yes - just installed and working

I’m not sure I’m aware of any plugins that have been updated to SB licences ?
Halion/GA had updates to work with it when C12 was released - although some new content gives licence errors with C11.

Wavelab obviously supports both - not sure of any others that do ?

Here’s a list:

Retrologue 2, Padshop 2 and Halion Sonic SE 3 have been updated to work with the Cubase 12 license, but vouchers for them haven’t been made available to owners of standalone licenses yet.

1 Like

thanks - although as you can see that information there is incorrect as it says the Grand 3.3.0 DOES NOT support elicencer but we know it does. Retrologue 2, Padshop2 and Halion Sonic don’t even feature. I’ve a feeling GA SE (?) is also one ?

Those plugins were updated because they ship with C12 and had to be compatible. So really Backbone and The Grand are the only ones ‘separately’ updated.

It seems that SB won’t release ‘updated’ licences for Absolute until they can do the whole thing in one go (a single upgrade licence)…meaning all the plugins etc will have to be updated first. It also means all those plugins will need to continue to support the elicencer whilst that happens.

Maybe that will be Absolute 6 ? but managing that migration and updates whilst keeping everybody running on a variety of licences is gonna be a total nightmare I expect.

anyway …

The GA update that said was still to run with my elicenser in fact doesn’t run with my elicenser anymore

Please make sure to update to Groove Agent 5.1.11 and press the Maintenance button in the eLicenser Control Center. I have an Absolute 4 license and it works for me.

yes - working here with a A5 licence

do you mean GA full version or the SE version (is there even more versions I lose track) ?

I have not got the voucher yet, been using the grand 2 and upgraded to TG3, since 2008, but no new code yet… how long is the waiting going to be ?