Solo: Bug or feature?

Press “s” on keyboard solos the selected track. Excellent.

Open “edit channel settings” window, “S” no longer solos selected track. Not so excellent.

Is this by design? A bug? Or a peculiarity of my system?

It works if you right click the Channel Settings window and enable Always on Top.

Fantastic thanks!