Solo Button solos all tracks for Multi-Timbral VEP5 instance

I have seen bits and pieces of this listed when searching for an answer on the web, but nothing definitive.

Anyone have a decent workaround for this?

  1. Create VEP5 instance with a Multi Timbral instrument using multiple MIDI Ports that are associated with different instruments (with each assigned to a different output within the Vienna Ensemble Pro engine)
  2. Open a Cubase 8.5 project, then display the rack, then add a VEP/// connection.
  3. Connect to the VEP5 instance
  4. From the Cubase rack display the Outputs which correspond to the VEP5 instance instrument MIDI Ports
  5. In Cubase, create MIDI tracks and assign each to a different Port of the VEP5 instance
  6. Try to solo one of the MIDI tracks or one of the Output tracks:
    Problem: All of the solo buttons turn red.

Anyone seen this and/or have any comments/workarounds for it?
It seems that if you solo a MIDI channel, in actuality only that track is soloed, but you wouldn’t know it because all of the solo button have turned red. Looking at it later you probably wouldn’t remember which one was actually the track you were actually hearing - please help! :confused:

Nothing from anyone?
No one has seen this?

No one can confirm that this is happening to them or that it is not (meaning that I am doing something wrong or my gear is setup incorrectly)?

No one from Steingberg, not even a moderator chiming in?
That is how you do your support?

This is a showstopper for me. If I can’t get past this then I have to try a different DAW than Cubase.
I’ll hold my nose and go back to Pro Tools, even as much as I hate their payment subscription model for PT12 and AAX nonsense. I went to Cubase because Pro Tools wasn’t 64Bit, but now that they are I will have to go back and “hope” that this behavior doesn’t exist there. If not then I’ll buy a MAC and make my current Cubase computer into another VEP5 slave computer.

Has anyone either seen this themselves, or run a similar setup and NOT seen this behavior?
If you have seen this on Cubase, is there “any” workaround?
Have you seen the Solo buttons function correctly using a different DAW (PT, Logic, Abelton, FL, DP, any others)?

I’d sure appreciate some comments good/bad as opposed to none :frowning:

Doesn’t happen here with v7.5.4 and I use VEP in the same way as you do. Sorry I can’t think of what your problem is.

Look at the top left there’s MSF buttons - uncheck all of them and try again.


That’s the way it works in 8.5.x.
At least when soloing the MIDI side.
Haven’t tried soloing individual outputs.
I’ll check it and edit.

Can’t remember about 7.x versions.

To be specific - I’m talking about a Rack instance of VEP5.
In one much used Template I have 4 instances of VEP5, each loaded with many (up to about 20) Play4 VSTis.
Each Play VSTi is fed by a separate MIDI input to VEP5.
Although some share outputs there are still many outputs from each VEP5 instance.

When I solo a MIDI Track in Cubase feeding ONE of these Play VSTis in the VEP5 instance ALL outputs from the VEP5 instance get soloed (though only the 1 MIDI Track).
This despite the fact that in the Inspector for that MIDI Track I have indicated which VEP5 output is associated with that MIDI channel.

Now, it hasn’t caused me a major issue because although ALL of that instances OUTPUTs are soloed, only the single MIDI track is.
So basically I hear what I want to.


Say I have (and I do) one VEP5 Instance that is Hollywood Strings. OK.
I solo Violins 1 A. Works as described above.
Then I add Violins 2 A (different MIDI Track , VEP5 Input, AND VEP5 Audio Output but the same instance) to the solo.
Still fine as described above. 2 MIDI Tracks soloed - ALL VEP5 instance’s outputs soloed.

NOW - I De-Solo the Violins 2 A MIDI Track - Violins 1 A MIDI remains soloed.
However, ALL of that VEP5 Instance’s Audio outputs are un-soloed, also. I can’t hear the Violins 1 A MIDI Track which remains soloed.

Workaround: I have to remove all solos and then re-solo anything within that instance I still want to hear.
Not show stopping but a pain.

2 Issues.
One a pain for me.

This issue (the ALL OUTPUTs SOLOED thing) was mentioned by someone else here - and I think someone in the thread did not understand that you CAN Indicate which output of the VSTi is associated with that particular MIDI Track.

But you can.
So Cubase KNOWS which output to solo. Why it solos ALL?
No idea.


Edit 1: I haven’t tried this with A SINGLE Multi-Timbral VSTi within VEP5.
My issue is with a number of VSTis each with a Stereo Output feeding a different VEP5 output.
You seem to be saying (on re-read) that EVERYTHING (all MIDI and AUDIO) is soloing when you solo just 1 MIDI track.
Perhaps you could try splitting up your BIG VSTi into a few single sound ones.
Then you might get my results - which are better than what I think you’re saying.

Tried just soloing just one of the outputs (instead of the MIDI side) from a VEP5 Instance.

Did the same thing in reverse.
It soloed only that one output but all of the MIDI Tracks feeding that VEP5 Instance.



Thanks guys for your comments. I guess for now I’m going with using Instrument tracks. I had to buy a second slave box to spread things around. I also took off all “stream from disk” from the PLAY engine and Halion Sonic. This makes the RAM footprint larger, but lessens the CPU hit. Everything is running fine now, although my electricity bill will suffer! I would rather use MIDI tracks and only a handful of VEP5 instances (instead of roughly 150 of them), but doing it this way has it’s benefits such as not having two tracks for each instrument (the actual MIDI track, and the VST Output track), along with a folder for each. Using Instrument tracks is a lot cleaner, and if I need another instrument I just make another Vienna Ensemble Pro vframe and put it in one of the 3 VEP5 servers as an instance. Still, if the Solo button issue ever gets sorted out I will probably go back to doing it the way that seems to be way more efficient using MIDI channels and Rack Instruments.

Thanks once again :smiley:

I’m late to the tread but I just came across the same issue. It’s really a pain. I’m not ready to transition to an instance of VE Pro per Instrument Track. But I’m not too far off…

Does anyone e have any updates on a workaround?

Just started working with VE Pro and bumped into this issue. Super annoying, especially as midi tracks can be now assigned to specific outputs of an multi-timbral instrument, but it doesn’t reflect to soloing / muting.

Quick workaround - which is not at all as convenient as proper soloing / muting would be - is to enable solo on midi editor and then selecting the midi tracks you want to be soloed. This only works when midi editor window is active. Select tracks you whish to hear solo, move the playhead to a position you want to start listening from, activate midi editor and hit play.

Hope this will be addressed soon - though i’d also like to see the memory / performance impact difference between creating a VE Pro instrument tracks for all instruments and using just a few VE pro’s as rack instruments with multiple midi channels and audio outputs.

If there’s no performance issue, i don’t see a problem in using VE Pro’s as track instruments, as they are a lot more convenient to work with (linked midi / audio).

Here’s another workaround, which works like “proper” soloing.

Enable Solo Defeat on all outputs (ctrl - alt - solo). After this, when soloing midi tracks, only
the corresponding audio tracks are soloed.

Bumping this becuase it’s quite annoying. I can always solo things in Ve Pros mixer, but I prefer doing it in cubase most the time