[solved] 8.5 bug - duplicate not working when MB open

I noticed that duplicating event with Ctrl+D is not working for me when Media Bay is open. If you close Meda Bay, Ctrl+D works again. Anybody else has this?


Is it always when MediaBay is open, or if the MediaBay is an active window (in focus)? Are you talking about MediaBay as a window or MediaBay Rack (or both)?

Only in case of MediaBay as Window, after hitting F5.
It was always like this? Hmm…, didn’t notice it before. :blush:


This is not MediaBay only. The same behaviour is if MixConsole is in focus.

Cubase has a “global” KeyCommands. You cannot assign one Key Command to more functions. And the Key Command triggers the function only, if the relevant window (and its content) is in focus.

Martin, did some checking, and you are mistaken in this regard. In C7.5 and C8 you can duplicate with Ctrl+D WHILE having MediaBay open via F5. Simply, you hit F5, MB opens, you drag a loop into project, and hit Ctrl+D – result = events are duplicated. No need to close MB.
In C8.5, for change, this does NOT work. You can NOT duplicate event with Ctrl+D while MB is open. After closing MB, you can copy with Ctrl+D as usual.
So it is a BUG, or maybe even a feature, huh, I wouldn’t be totally surprised…

OK, after playing with it a bit more, there are also other shortcuts not working while MB is open with F5. Ctrl+Sfift+S is not working. Also you cannot open Key Commands with shortcut, I used letter K. What is going on??? Everything works fine on C8 and C75. I copied preferences from C8, maybe that is the problem. Will try with preferences disabled.

Alright, it seems I got to the bottom of it. After disabling preferences, it works as expected. So it is a preferences fault. After installing 8.5 first I copied just selected preferences files, like key commands and so. Then I noticed my mediabay was off, because I use volume databases. And my remote devices were gone, and external effects… So I just copied entire C8 preferences folder into the new C8.5 folder. All settings transferred well, but now I have these problems with shortcuts. I have backup of original preferences folder so I can copy back any original file. Any suggestions which file is responsible for above described problems? Thnx.

Turns out problem is solved if I delete Defaults.xml. But this means I lose my Remote Devices setings, all custom color setups and current preferences. Sweet…
Ok, colors I can export. Preferences too. And remote devices mapping too. A bit of work, but…, ehh, it is the same with every new version of Cubase, one could expect that we would get used to this by now.


Thank you for investigating. Would be interesting to find, which preference (if any particular) affects it.

Well, trashing defaults.xml helped. Turns out it was a good thing to do, Cubase seems much snapier now. Also I didn’t get any crash on exit since, but we’ll have to wait a bit and see how it stands.
Strange that my settings were not picked from previous version. Manual says that preferences are automatically transferred while updating, as long as previous verion is not older than C6. So in my case Cubase should ask me to transfer settings, but it didn’t, I had to do it all manually.

Mmmm … I just had to install 8.5, start it up and after an initial once-off delay, everything – and I mean, absolutely everything, even recently open file list, was exactly the same as in 8.0 but yes, this was the first time it’s gone so seamlessly, YMMV, as they say.