SOLVED / Akai LPD8 stopped working with Cubase 9

I’m using an Akai LPD8 to tweak the Track Quick Controls in Cubase. It’s working perfectly fine in Cubase 8.5, but in Cubase 9 it seem to have lost the connection to the quick controls in the Inspector.

  • -> I can map the MIDI ch. and address QC 1-8 in the Device Setup menu using the learn function.


  • -> The MIDI Port Setup in Cubase 9 is identical to the setup in Cubase 8.5, which is working.


  • -> I got plenty of signal in the MIDI Activity meter when tweaking the controls on my LPD8

According to my logic the above is telling me that it should be working also in Cubase 9, so why is it not?
Any suggestions what I should look for in order to fix this?

EDIT: I manage to make the LPD8 work with the VST Quick Controls, but that doesn’t help since I need to use the QC also on audio tracks, sampler tracks etc. And, to me it makes it even more strange why I can’t make it work with Track QC.

Hi,

Can you share a screenshot of your Track Quick Controls settings, please?

Make sure the VST Quick Controls are not used (Input = Not Connected), while using the MIDI Port for the Track Quick Controls, please.

Hello Martin - thanks for your interest.
Just to be absolutely sure, I have again tested a bit this afternoon and I can confirm that all in my previous post is correct. It’s working fine in Cubase 8.5 but the exact same setup does not work in Cubase 9.
VST QC is not connected.

I would be grateful for your any suggestion how to fix this.

Here’s a screenshot of the Track QC in Cubase 9.
Track QC Cubase 9.tiff (123 KB)

Hi,

Are you sure your LPD8 sends data on MIDI Channel 2?

Could you try to disable pick-up mode? Or are you sure, you “touched” the Value of the QC?

Hi again -
Yes, I’m sure about ch. 2 since I’m using the learn function in the Track QC setup to map whatever channel/cc the LPD is sending out. In the LPD editor I can choose to send on all ch. 1 - 16 ch. and it’s been tried and tested.

Pick-up mode have been enabled/disabled during my testing - both works fine in Cubase 8.5 but not in Cubase 9. And yes, I have turned the knob on the LPD beyond the pick-up value :slight_smile:

The most fantastic thing happened when I trashed some files in the preferences. The Track QC’s are now working perfectly with my LPD :wink:

:slight_smile: