(SOLVED) (ANDROID) The speed of the project is accelerated in Bluetooth headphones

without connecting bluetooth headphones, the project is absolutely normal, but when I connect headphones, the project accelerates and the sound becomes high pitched, as I understood this is due to frequent sampling, I also changed it in the phone settings, and it bore fruit the sound became slow… I have ldac headphones with a sampling rate of 96, and cubasis 3 has the same sampling rate, I don’t understand what the problem is at all, also, the application does not see headphones, but I can hear everything with it, everything is OK, I tried the same problems in two versions of cubasis, help :smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear:


Hi @orekhov69davyd69

Please give it a try to re-select the “Sample Rate” of the project located under “Project/Sample Rate”.

Does this help resolving the problem?

Best,
Lars


Mixdowned with a bluetooth connected TurtleBeach headset


Mixdowned without bluetooth connection + device speakers

Everything else in Cubasis is exactly the same.

I don’t understand what you’re talking about. , there is a simple rate in the settings , but it is not clickable , it cannot be changed , it is possible to change only bit resolution, but it does not change anything, there are no such problems in other recording programs…

From what i gather, there is nothing within cubasis that changes but some how the bluetooth device acts like a master and cubasis acts like the slave… nothing will change in cubasis visually but the BT device will adjust parameters somehow. The BT device somehow overrides the parameters and acts like a master… it shouldnt do that… even if there were parameters within cubasis that could be adjustable the BT device should have the power to overide any value unless its dictated by cubasis itself (by the user)

As you can see in my case… even in my mixdown (key and speed/tempo) are different when i have my bt headphones on or when i totally shut my bluetooth off… which under no circumstance should be the case, as rendering the mixdown is a computing matter and not a hardware matter. Yet it doesnt seem the case.

I dont think this gonna be fixed quick as they havent figured this totally out yet.

So you have 2 options imo…

  1. Use a hardwire headset…

Or

  1. Google how to unlock the develloper options on your amdroid and tinker with the bluetooth options yourself

There are several options as codecs and sample rates etc.
You’ll have to turn on your BT headset/headphone before changing the settings as every BT device has their own profile. So first turn on your BT headset/headphone and then adjust the settings so it changes things according to your BT device.

I dont know which settings work the best, i just know the settings are there.

Hi @orekhov69davyd69

Sorry for mixing things up between iOS and Android here.
Of course the project sample rate is fixed on Android and can’t be changed.

Best,
Lars

1 Like

And what is the result? is there simply no solution ? are the developers aware of the problem? is there any way to fix this in the future?

yes, I tried all this in the developer settings, but it makes fast slow, or vice versa, does not return to normal, I do not understand why you say that Bluetooth can change something and it is to blame… there is no such thing in other daws on android, bluetooth headphones work well there, the same bandlab, but cubasis is something native to me and I would like to work in it, the voice quality is very good in cubasis than in the bandlab there it is disgusting

Yh no idea why it has problems with bluetooth… with you iy speeds up the wave, with me it slows down the audio,there was this other forum member that had weird behaviour with the classic drummachines when turning on his bluetooth… apparently it differs per bluetooth device/brand. We only can hope steinberg can figure it.

most likely, the developers just don’t give a zoinc about the android version, they didn’t even do full-screen optimization, why the hell do I see this strip from above, in 2024 it’s a complete cringe , it says a lot

Hmm no the android bar on top has to do with some android setting i think… i have cubasis in full screen on every screenmode. No strip.

Hi @orekhov69davyd69

Cubasis for Android does not support Bluetooth (see Cubasis feature comparison).

In addition, using Bluetooth phones with a DAW adds system-related latency, which makes it impossible to trigger real-time signals such as an instrument etc…

Best wishes,
Lars

“Bluetooth phones with a DAW adds system-related latency” that counts the same on ios yet ios supports bluetooth… so thats a weird statement.

And this is the first time anything is said about bluetooth on android not being supported… there have been several topics on android bluetooth issues and never it was raised that bluetooth on android was totally not supported. Hardly anybody ever complained about latency as most people understand there is latency on bluetooth, far more importants for a lot of people would be to be able to mixdown the tracks by using their desired bluetooth headphones as bluetooth is pretty much a standard nowadays. I got 200 euro bluetooth headphones but now i have to get hardwired headphones only to operate cubasis while every other bluetooth audio device in the book works just fine. Thats kinda weird imo.

a smeared response from the developers, well, everything works in bandlab, what he says I just don’t understand, now absolutely everyone has Bluetooth headphones, it feels like the developers are back in the year 2015, at least the one who answers. WHY DID YOU SEND ME A SCREENSHOT, I’M TALKING ABOUT THE STRIP ON THE SCREEN WHERE THE CAMERA HOLE IS this area is filled with black as in this example

Hi all,

Sorry for my previous response, which might have been misleading for a few users.

While Cubasis for Android can be used with Bluetooth audio devices, the app does not provide additional settings, as it is the case with Cubasis for iOS.

Furthermore, the performance of Cubasis for Android is strongly related to all given devices in use.

I gave the topic a short check myself, pairing a set of AirPods Pro with a Samsung Galaxy tablet and smartphone. In both cases, playing back audio and MIDI files in Cubasis worked as expected. Same goes for our engineering, who double checked the issue using Bose 700 BT phones.

For those of you experiencing the issue, please provide us with further details about the Android device and OS version and BT device in use.

Thanks,
Lars

I have attempted to connect via Bluetooth with the following earphones:

-Tozo T12
-Sony WF-1000XM4
-Sony WH-1000XM4
-Sony Linkbuds
-Earfun Ear Pro 3
-Huawei Freebuds4

On the following phones:

Oppo A54S -Android 13

Google Pixel 6a - Android 14

None of these combinations work.

I could only get it to work with a Shure Vm88+ usb microphone with wired headphones attached. Clearly I don’t want to have to attach an adapter or microphone just to listen back to tracks so I have got a refund.

As a developer myself, I find it a little odd that this is such a challenge for the Steinberg team, there are standardized APIs for handling BT on Android, and most other apps I have tried have no problem whatsoever handling this. Whatever could be the problem? Makes me believe they are not really bothering. It does raise a lot of doubts about buying future products to be honest. Anyway, let us know if you ever sort that out, I’ll be moving to another DAW on phone and consequently also on PC (no point in purchasing latest Cubase if I don’t even have the advantage of compatibility between mobile and PC)

They used a Master/Slave protocol for BT earbuds/headphones which shouldnt be there…
For BT Midi it would logical to use such protocol when you would be using external hardware (like midi controlers etc) to dictate who is the desired Master and who is the Slave (who is controlling who in order to determin which appliance overrides the other)

This should not be the case regarding BT earbuds/headphones.
Other than latency, BT earbuds/headphones should have no different behaviour as their wired equivalent. Somehow BT buds/phones have influence over cubasis in any way or form.
Why this is the case is a mystery… could be misprogramming or maybe a philosophy error that was overlooked (maybe treating BT Midi and BT audio as the same module while it needed to be 2 different ones).

As stated in the cubasis android specs… BT Midi is supported, while BT audio is not.so Bluetooth in itself is handled as a BT Midi module and BT audio just tags along.
This is the only logical reason why different BT buds/phones display different types of weird behaviour (there been reports of upscaling/downscaling/certain iap instruments not working as intended/having no audio at all… different brands/models of BT buds/phones displaying different desired behaviours) because they act like different BT Midi devices (the ones they have resemblances with).

But hey, what to i know… i didnt program the cubasis app :disappointed::persevere: all i know is that my productivity is staggered because not being able to handle my BT audio in a normal better takes a lot of fun out of daw process and is partly demotivational and not having solution or a fix is getting me nowhere.
Switching to wired headphones takes away the abillity to charge my device and use headphones at the same time. Going through all different BT buds/phones to maybe find a brand/model that finally works is a tedious process and im not prepared to go through the headaches.

1 Like

Hi all,

Cubasis uses Google Oboe for audio I/O which means that it should support all device combinations that Oboe supports.

Since we are unable to reproduce the problem ourselves using Apple AirPods Pro and Bose BT devices, we will try to get hold onto a pair of Tozo T12 to further evaluate the issue.

In addition, please share your list of devices in use @CJ_Monster.

Best,
Lars

Thank you,
I appreciate the effort. Will be coming back here to check for news.