[Solved] Anyone having e-licenser issues with 10.5?

Hi, just downloaded 10.5 PRO update, went to activate in E-icenser Control Center, was told to upgrade to latest version, done that, now I keep getting “Reading eLicensers” - and nothing happens, and when I move the window, this is underneath…repeatedly, have deleted and re-installed (ELCC), restarted countless times, but it seems is not recognising my e-licenser, which was 100% working fine until now.
Obviously now I cannot open 10 or 10.5…

Suggestions welcome/appreciated…

First, thank you for your purchase!
Could you please send a support request via MySteinberg mentioning my name in the subject? It would be helpful if you could include a Windows 10 system information file (.nfo) right away. I’ll have a closer look then.

Hi, I sent a request about half an hour ago (234932) obviously before I got your reply…to be honest I got annoyed and did a system restore to this morning, now going to go through the process with fingers crossed, if it fails again I shall do what you said.

Thank you for the reply.

Solved via support ticket.