SOLVED! Avid Artist/Euphonix + Cubase Pro 8.5 = not working

Hi All,

I bought a Euphonix MC Control v2 second hand and I tried to make it work with my Cubase 8.5 system.

I registered my controller at AVID, downloaded the installer, and set it up.

I also registered it on MySteinberg (Register new hardware), received an activation code and activated the EuCon licence on my dongle.

In Cubase I added EuCon as a remote for Cubase.

I connected my controller and it is recognised by the EuCon software, I can see it appearing in the the software, I am able to edit the soft keys etc. however when I start Cubase I am not able to control it at all. I don’t see any of the channels, transport functions don’t work etc.

All software and firmware are up to date.

Do you have any suggestions where the problem might be, or what I can check in order to make this system work?

Thanks in advance for any reply

Ok, so after spending some time trying to reconfigure the system I ended up installing an earlier version of the EuControl and now everything is working fine.

Thanks for posting back, might help out someone else in the future :slight_smile:

Have fun with your new control surface!

Hi there Dada, I’m having a similar problem. Can you let me know what version of the EuCon software fixed the problem please? I’ve tried 3.41 and 3.32 without any luck. Cheers mate.

What version are you using now that worked? I am having the same issue. Would really appreciate the help, been trying everything!


3.40 works.