(SOLVED) Bug with RenderInPlace on audio track

Well I was messing with an audio loop and some heavy FXprocess… to unload some I tried to render in place with channel settings.
And the audio resulting is empty, or only containing a little tail of the FX. (I even tried to freeze that audio track…and when done, pressing play gives me no audio, like the render in place)

Same FXs on a midi part (instrument track) and the result is fine !

Tried all the render in place options, cant do nothing. Only the first option worked, but only render pure audio and keeps the FXs in insert, so useless, but then it works.

I then tried a last thing to check if maybe a 3rd party FX could alter the render. So took an audio clip (wav) and put the Steinberg Chorus with noticable settings. Render again gave me a blank render.

Ok i had the monitor turned on for that audio track and that was the problem.
Retried the export without monitor and the result was fine, my audio clip with all the FX chain inprinted.