[SOLVED] But still an issue! Cubase Pro 10.5 Not recognising EZDrummer 2

Hi all,

With previous Cubase Pro Upgrades. Some plugins were not recognised by Cubase but to fix, I simply had to go into Cubase VST Plug-in Manager and direct to the folder holding the EZDrummer.dll file. For EZ Drummer 2, I just had to direct VST Plug-in Manager to…

C:\Program Files\Common Files\VST3\Toontrack

… and after refreshing, Cubase would recognise the VST instrument.

After upgrading to 10.5, Cubase does not recognise any form of EZ Drummer 2. I know EZ Drummer is working becoause it works in standalone mode.

Anyone have a fix?
regards,

[SOLVED]
I found out that in order for Cubase 10.5 to recognise EZ Drummer 2 the EZDrummer.dll must be in
C:\Program Files\VSTPlugIns
Then refresh Cubase VST Plug-in Manager…
Cubase 10.5 will automatically black list it… But just reinstate the dll and it works.

It should not be a problem EZ Drummer 2 is a 64 bit VST instrument. 10.5 needs a fix…

Same issue here. Some plugins (Toontrack) not recognized. Projects with EZ drummer couln’t find the plugin in Cubase 10.5 In Cubase 10.0.50 it just loads fine. Thanks for the work around solution! I will try it as soon as I’m back in my studio.

Found out that the same issue occurs with the NI Kontakt plugins.

Work around solution is also the same: copy the dll files to C:\Program Files\VSTPlugIns and it works.

Cubase 10.5 needs a fix indeed.

I had the same issue and solved it by going to Studio/VST Manager and adding the folder location of my Native Instruments Komplete to the list where Cubase look for the plug ins. Probably easier than copying files to another folder - and might be a possibility of messing up the Native Instruments folders ??

Good advise!

It’s better to leave the files in place indeed for “you never know…”
I changed my setup and deleted the copied dll files and added a link to them instead.

It looks like Cubase 10.5 can’t find VST2 plugins that are put into folders.

I have the same issue with Omnisphere 2.6.2. Cubase Pro 10.5 blacklist sboth 32bit and 64bit versions. When I try to reactivate Cubase crashes completely, no messages. I’m running Windows 10.

PS I have Trillian and it loads, no problem.

you can try to see if this helps…


https://www.steinberg.net/forums/viewtopic.php?f=286&t=173409&sid=3eae995fdd801f7a19041679039a8b9f

Yep, that pointed me in the right direction. Omnisphere was blacklisted. When I tried to reactivate I reactivated the wrong dll.

Now I’ve reactivated the correct dll Omnisphere works fine.

It’s still strange that when I first run 10.5 it put Omnisphere into the blacklist and the comment said ‘crashed’.