[SOLVED] cannot hear sounds when importing midi file

cannot hear sounds when importing midi file it is very disappointing , as well when creating you own custom score you cannot hear the music play , as well no auto scrolling when playing music .

Patrick Mimran

Could you try going to play mode and selecting the “Play” > “Apply Default Playback Template” menu item? Does that fix the issue?

We’re aware of the viewport not following the playback line and this will be fixed in an update soon.

1 Like

Hi Patrick,

I have earlier replied on your other post https://www.steinberg.net/forums/viewtopic.php?f=246&t=103678

does that help you?

Hello

sorry i did not saw your last post , i tried your suggestion and it worked fine thank you

Patrick

I tried the suggestion, but it did not allow me to hear playback on a hand-entered file (as I can on some other Dorico files). I’m open to other suggestions as time permits.

Derrek,

with your hand-entered project, please go to Play Mode. On the right hand side is the list of VSTInstruments. Is there already an instrument, i.e. HALion Sonic SE loaded? If not, you can add one yourself. At the bottom you can find a ‘+’ button. That will add the instrument and from the drop down box you can choose HALion.

If there is already an instrument, you can open the editor window. Left to ‘HALion Sonic SE’ there is a strangely looking ‘e’ button. Click on that and the editor window will open. Here you can see what sound is loaded and also,
if playback starts, it will show some activity when MIDI data arrives, as well as the virtual keyboard playing. So if that does for you and still no sound, then you should check your audio driver.
Choose Edit > Device Setup and see if the wanted driver is chosen.

Ulf,
Thank you for the prompt response at what must be an incredibly busy time for you and your mates.
I can see the Sonic SE2, and its meters show sounds being processed as I play the file, but no sound comes out my speakers. The setting for Device setup is the Low Latency ASIO at 44100, and I let it grab exclusive control. Oddly enough, this setup works for other files including a newly entered file last night; so you can see why I am puzzled by the anomaly this file presents.

Even when I click keys on the Halion-screen keyboard, the Halion shows sound being produced/measured on the VU meter, but no sound comes out.

I’ve attached a file, if that will help.
whiteAndRed.zip (611 KB)

Hi Derrek,
thanks for the project file. From the data I can pretty clearly see, that you won’t hear anything. In the project data should be information contained, of how the output of the audio engine maps to the actual audio driver. But this link is missing in the data, so the engine doesn’t know where to send the data to and hence it sends it to void, so you won’t hear anything.
As to why that happens, we have no clue at the moment. Is this happening with any new project that you are creating? Because you said with some projects you do get sound out.
For tracking, I’ve entered this issue in our bug base [Ad-244]

Last night I created another short file from scratch but entered pitch via my MIDI kbd instead of via the numbers on my QWERTY keyboard. I submitted that file for a layout question at

https://www.steinberg.net/forums/viewtopic.php?f=246&t=103843&p=570271&hilit=FYI#p570271

That file had no problem with sound. I’ll be interested in what your staff discovers about the file that doesn’t work. For may own purposes I may try exporting as XML and opening in a new file to see if that will fix the sound problem.

Thanks for taking this on.

It solved my issu and I hadn’t even asked. Thanks greatly!

1 Like