[SOLVED] Can't resolve "Connection error - Cannot open socket"


Hi everyone,
I’m trying to set up VST connect SE on my C12pro Windows machine running Windows 10.

I’ve tried closing ALL programs, even background processes. I set up static IP and port forwarding. I checked windows firewall and the permissions are set to accept traffic from VST Connect. Everything seems fine.
I then used TCPView to check the ports, nothing is using UDP ports 51111 - 51113. Sorting the list in TCPView (screenshot attached) shows nothing using those ports. To be sure, I also did a search for anything beginning with “51” and nothing shows up. Seems the ports should be open!

And yet, still the same error message.

Is there anything else I can try?

Thanks ahead of time for your help.

This can happen if another app tries top use the same connection port. Usually this resolves itself (did you try again the next day?), else you may want to check what you have installed recently.
This possibly can be analysed examining firewall settings, but that is a tedious task.

Thanks musicullum.
I have tried numerous times over many days, even weeks. In fact, I had the same issue a year ago when tried using vst connect.
Is there a guide to troubleshooting that can go deep into it? I’ve added firewall rules opening ports UDP 51111-51113. Using both tcpview & netstat (command line), I can’t find anything else using these ports. Do you know of any other ways of finding what is occupying the ports?

I have found a solution!

After much sleuthing, it appears that a Windows update at some point created a situation where some ports were bound, but not used. Since they aren’t in use, TCPView and netstat does not register them, because they aren’t actually in use. The specifics are outlined in this stackoverflow page.

The following worked for me to resolve the issue:

  1. Click start, type cmd to find the command prompt, RIGHT CLICK on it and “Run as administrator”.
  2. Type the following:
net stop winnat

Hit enter. Windows will shut off a process.
3. Type the following:

net start winnat

Hit enter. The same process will start again.

  1. Open Cubase and try VST Connect again. For me, this resolved the issue but there are other workarounds suggested in the aforementioned stack overflow page that may also work.

Wow, that’s remarkable. Thank you so much for this!
After reading through the links you mentioned, it look as though this only happens when Hyper-V is involved in some way - else, why don’t we (and pretty much all other users) experience the same problem?

Yea, I guess so. I don’t even know what Hyper-V is and I’ve certainly never used it. My machine is running windows 10 pro so I guess it came as part of the install.

Anyways, I successfully ran a vst connect session last night! Glad I was able to solve the problem!!