[SOLVED] Clicks and pops after Windows 10 upgrade

So I finally bit the bullet and upgraded to Windows 10 Pro 64 from Win7x64 (partly to fix RX7 which wasn’t working) and now I have lots of clicks and pops when I playback anything in Cubase 10 with my previous settings. Oddly, Ableton Live 10 and Cakewalk don’t have this issue after the upgrade, although I detected one or two clicks in a large Reason project.
At first it was quite bad. Even with a completely empty project loaded and not playing the real time peak meter was averaging about 50 percent and was spiking pretty frequently. So I did a little searching here and found a few suggestions. I disabled every Windows service that I knew wasn’t necessary and got my load down to 1.6 Gb RAM (with Cubase closed). That helped some but not enough. Then I saw the suggestion to change the Processing Precision from 64 bit to 32 bit. That helped quite a bit more and now I can play a 3 minute piece and only hear 3 or 4 clicks during the whole playback, but I heard none before upgrading and this is the same project with the same hardware, just the OS upgrade.

I have Steinberg Audio Power scheme enabled, and ASIO Guard set to Normal. Under Windows 7, I was able to play back projects at 64 samples, now I have to increase that to 256 to get clean playback.

Anything thing I’m missing? Any help would be appreciated. System specs in my signature.

you might just want to uninstall and resintall Cubase. It seems like, for whatever reason, the change in OS made Cubase cranky.

Forgot to mention, I did that already. First I tried just the 10.0.15 update, but when that didn’t work, I downloaded the full installer. No improvement from that.

Also, when I run LatencyMon, I get pretty good results. My highest measured interrupt to process latency is around 70 us, highest ISR routine execution time is around 80 us (always Direct X), and highest DPC routine execution time is 180 us (nVidia kernal mode driver).

So I finally found the fix for this. Apparently the Windows 10 driver for the TI Firewire controller is a problem. So I downloaded the ‘Legacy Texas Instruments 1394 OHCI Compliant Host Controller’ Windows 7 x64 driver from MS and installed it and Viola! I can run the same file I initially mentioned at 64 samples with zero clicks or pops.

Thanks for everyone’s help!