[SOLVED] Crash when using IAA

Hi!
I’m trying to insert an effect on my track using IAA and Cubasis 3 simply closes. I’ve followed the steps suggested in this other post, but it still closes when I try to insert an effect.

Here are my specs:
Ipad 6th Gen 32gb
IOS 13.6.1
Cubasis 3.1.2

IAA apps I’ve tried include: AUFX: Space Reverb, FD-1 Filter Delay, RF-1 Reverb

As link above, I’ve started a blank project, no tracks, closed all apps then restarted ipad. Started up cubasis, added a new track and add insert/send effect, inter-app folder. Clicking on any app closes cubasis.

Thanks!

Me too. The most current version of Cubasis that my iPad Pro auto-updated to will crash when I try to load interapps, in this case iConvolver and pretty much all others. My workaround has been load one or two of the Waves plugin, which are similarly demanding but more or less native. For some reason, it will let me load an interapp if it’s not the first and perhaps only insert effect loaded. My theory is that loading the Wave plugins first somehow alleviates the choke point causing the CPU to overload and crash. Anyone else?

Hiya!
I just tried loading waves before loading an interapp plugin but mine still crashes out. I think there is a new 3.1.3 update that will address this iaa crash, can’t wait for it to hit my ipad!

It could take more than one try. Seems a lot of the crash and noise issues relate to how efficiently it uses the CPU. It might crash even more on an iPad Air3 than an Pro 10.5, tho I’m not sure which has the better processor. I also run these plugs in C2 on an Air1, so we know they aren’t too much for the iPad. Anyway, the most recent iOS or C3 update is causing the misloading.

Honestly, I’ve lost tracks of all the bugs I’ve officially reported on C3, faithfully submitting sample files, seldom receiving any follow up.

Is CBT-2095 the issue/case number?

Hi all,

This issue should be resolved in Cubasis 3.1.3, which is available for immediate download on the App Store:

https://www.steinberg.net/forums/viewtopic.php?f=300&t=198001

Best wishes,
Lars

Hi Lars! The IAA plugins now work as expected :slight_smile: Thank you (and your team) for such a quick fix! Cheers!

This update made a mega difference - now my bias fx will load like it should!

I was preparing to refund my cb3, but now i wont do it.

Thank you all, who got it work - cb3 is much nicer, but bugs must be fixed quickly. Luckily one less bug, witch was a bigone!

Thanks for your immediate reply, spiralmaschine and Heavy!
We’re glad to read, that the 3.1.3 update immediately solved your previous issues!

Stay well,
Lars

Update:
Still buggy.
If i create mixdown, then the track (in insert effect i have only added bias fx) is mute and doesnt come through.
If i listen, then it plays like it should.
When i freeze track, then there will be only track with no waves (straight empty line).
Deamn!!!

Please fix it!

Lars i did a video also.
I noticed, when i switch bias fx off/on from insert effects, then it renders like it should. But sometimes not - you see in the video.

https://youtu.be/_H3E_g2H1oE

Hi Heavy,

Thanks for your message.

The hofix included in 3.1.3 resolves the issue, where loading AU plug-ins can lead to render Cubasis unreliable, which no longer should appear.

Apple’s Inter-App Audio format comes with many limitations which we’ve summarised in this article: https://www.steinberg.net/forums/viewtopic.php?f=183&t=104551. Please note that Apple did release Audio Unit support as the successor of Inter-App Audio, which has been discontinued quite a while.

Hope that helps.

Best wishes,
Lars