Solved - Cubase 12: MIDI Remote problem

I’ve got huge problems getting MIDI Remote to work. While I don’t have a controller that is supported out of the box, I planned to write one at least for my Novation Impulse 61.

Now the problem:

I don’t have a “MIDI Remote” tab in the lower zone at all. When I go to Studio/MIDI Remote Manager I can’t do anything there. The add surface button does nothing, all other options are greyed out (not working). The only thing I can do is importing a script. But it looks for *.midiremote filetypes which of course are nowhere to be found on my PC.

What am I doing wrong? Do I have to setup something special in the Studio settings for MIDI devices? Does it need Windows MIDI or DirectMusic or both or what?

I’m a bit stucked at the moment.

2 Likes

I forgot to mention that all my MIDI devices are connected via USB. Can that be a possible cause?

I don’t even have an old fashion MIDI cable anymore, otherwise I would give it a try.

Okay, I found it.

Windows 11 anti-virus prevents the necessary components to be installed. Switching the virus-guard off during a reinstall was the solution.

1 Like

I’m on a Mac but it sounds like the same problem I have, unable to add a surface ands all greyed out options. Do you know what the necessary components are that need installing?

1 Like

Sorry, I`ve got no idea. The subfolders and files in the \Cubase 12\midiremote_factory_scripts\ directory seem to be the same. I don’t know what the difference really is. Probably something in the installer.

hi, i am having a huge problem with midi remote.

  1. it doesn’t let me import more buttons than the buttons i have.
  2. when i open a project it works for 3 second and i’m talking about start/stop/rewind etc.
    I have an akai mpk 249 and i’m running windows 10.

I also don’t have the MIDI remote tab. In the bottom zone I have Mix Console, Editor, Sampler Control, Chord Pads, and the settings icon. When I click on the settings icon it shows those four items, and allows me to remove or re-order them, but no MIDI Remote is to be seen.

There is a MIDI Remote mgr in the Studio menu, but it doesn’t look anything like what 54 Domingo Ave. shows in the video, and doesn’t show the MIDI surface I have plugged in (an X-touch mini).

What am I missing?

MacOS 12.0.1, Cubase 12.

1 Like

Well, I just rebooted my mac, and now the MIDI remote manager tab is there, and it seems to work.

Hello.
Exactly the same problem with Window 10. Will I need to turn of the anti virus?

Yes, you need to completely turn off any Antivirus before installing Cubase. You should of course turn it on again after install. But when I was doing it, Cubase won’T install correctly, when anything anti-virus related was active during install.

Well - a good installer should take care of this or at least tell the user that something went wrong during install. But for whatever reason Cubase doesn’t do that.

In Studio → MIDI Remote Manager the “Add Surface +” also isn’t responding.

Did you try turning off Anti-Virus in Windows? I have W11, turned it off, and still haven’t been able to get Remote working in the Lower Zone.

Mine is same situation. I try clicking on Add Surface + and it doesn’t respond.

hello
i got an Akai MPK249 , Cubase Artist 12 and windows 10 , i got the same problem with controller , did you get it fixed ?
cheers !!

no unfortunately not

I’ll post if I get it worked out. I tried the suggestion above to turn off antivirus Windows 11, reinstalled, but still same with no lower zone option for MIDI Remote.

Did you uninstal before? I did that and manually deleted the %user%\AppData\Roaming\Steinberg\Cubase 12_64 folder. Only then I reinstalled Cubase 12. That worked for me.

Rainer - Yesterday, I did reinstall (less virus sw) but that didn’t make the difference, at least immediately. I didn’t remove any folders other than the VST instruments for HalionSE I had from old versions (way back to LE/SE and Artist). Only then when I restarted Cubase did Remote finally show in the LZ. MIDI Remote API - UI focus feedback - #20 by John_Ehlers

Hello friends,

Tried the uninstal (manual and ordinary) also disabled antivirus. I can not bring up the Midi Remote tab…I dont get it

If you have a working script for the Novation Impulse 61, I would like that too…