SOLVED: Cubase 12 - Waves / Plugin Alliance plugins load very slow


I noticed that with the newest version of Cubase 12 I have issues loading third party plugins during playback. Cubase freezes for roughly 30 seconds to one minute and the playback stops. Then the plugins get’s loaded and Cubase unfreezes. Tested with several plugins from different vendors, always the same outcome. But this does not happen with Steinberg stock plugins.

Totally annoying.

My system:
Cubase Pro Version 12.0.20 Build 263
Windows 10 Pro 21H2 Build 19044.1645

Totally annoying . steinberg needs to do better ASAP

1 Like

I tested a little further. It seems like this behavior only happens the first time you load up a specific plugin during playback in a new session. When you load up the same plugin again in the same session it works like before.

Anything to do with piracy protection?!

The longest freeze I get with specific plugins from Waves, like the OneKnobs series or MV2. Also have the issue with other vendors like Plugin Alliance (Blackbox HG2).

Had no issues before, seems like this was introduced with the latest versions.

I’ve seen the sort of thing you’re talking about, as well. It’s not necessarily the first time loading a specific plugin, but rather the first time loading a plugin in that specific group of plugins, at least in the Waves case. For example, let’s say you load something in the CLA collection, maybe first the vocal plugin, which takes a very long time to load, then the mixdown plugin, which now takes a shorter time as do further instances of the vocal one. I strongly suspect it has to do with software protection, where one authorization is needed for a specific set of plugins, but another set of Waves plugins (e.g. if you were to load SSL EV2) may need a different authorization.

I’ve also seen this with non-Waves plugins, such as Arturia, NI, and maybe even PSP Audioware. Probably others, as well. (PSP uses iLok, but the others use their own mechanicsms.)

One other possibility could be, if it is the first plugin load of a specific plugin in a bootup session, and your plugins are on hard disk (like mine), and the first load is slow but the second load of that specific plugin is fast, the difference between having the plugin cached in memory versus having to be read off hard disk.

I can’t say I’ve noticed any difference here between Cubase 12 behavior (in any of the three versions to date) from Cubase 11 behavior. I have a few times, however, had Cubase 12 hang permanently (i.e. until killed with Task Manager) on loading a plugin (I know one time was PSP InfiniStrip – I don’t recall if that was in 12.0.10 or 12.0.20, and that plugin usually loads with no problem). Early on, I was also seeing some hangs when making major changes in some plugins (e.g. loading a different kit in Superior Drummer 3), but I haven’t noticed that recently (at least in 12.0.20), though that could also be because I’ve treated this sort of area as walking on eggshells and only made those sorts of changes with playback stopped. :slight_smile:

1 Like

So I tested a little further and actually it really seems to be a Cubase 12 issue. I did a quick test with the Waves MV2 in an empty session with only one audio track in Cubase 12 and Cubase 11.

The loading time on Cubase 12 is more than 10 times higher than on Cubase 11. The program completely freezes for around 20 seconds while in Cubase 11 it’s more or less immediate. Only while playback you get the usual hickups. Also as described above, once one plugin instance was loaded, the issue is gone with further instances in the same session.

I really hope that someone from Steinberg will look into this. At this time Cubase 11 is so much more stable than 12 on my system. Actually Cubase 12 is the most unstable version I had so far since 10 years. :roll_eyes:

Video Proof:

Cubase 11:

Cubase 12:

Did the same test with several plugin vendors and could narrow it down a little. The issue comes only up with:

  • Waves (Machine Activation)
  • Plugin Alliance (Online Actication)

And actually it happens for all plugins of those vendors in each session. I have to load up one instance of each plugin with the 20 sec loading time before I am able to open further instances with the normal loading time.

The issue does not come up with:

  • all smaller developer plugins I have and
  • iZotope (iLok Activation)
  • Native Instruments
  • Softube
  • PSP
  • Voxengo
  • Melda

So as I still think it has something to do with checking licenses for the products in some sort as both Waves and Plugin Alliance seem to phone home when loading their plugins. BUT why wasn’t this an issue in Cubase 11 and all previous version? Why has Cubase 12 a problem with that?

Can someone else replicate that on their system as well? Maybe it is a specific thing on my end, then I need to investigate further.

Thanks and cheers,

I have not done any comparison tests on my system in this area (and really haven’t gone back to Cubase 11 since starting with Cubase 12). One sanity check on your tests, though: Were these tests both done after a clean boot session or, if not, were they at least done after having loaded the plugin in question in one of the versions of Cubase, then close that version of Cubase and run the tests in each of the versions. The reason I ask is to rule out any additional first time startup overhead for loading a plugin after a reboot. In particular, plugins (and any support software they use) wouldn’t be likely to be cached in memory the first time after a boot, but loading them a subsequent time after that boot will likely have them cached in memory.

With respect to Waves start times, and this authorization check (which I’m pretty sure is what is represented by the spinning “W”), I have seen these, but not for loading of every plugin, only ones that are the first authorization within a specific family of plugins that shares the authorization. So, for example, if you were to load RComp as a first plugin in that series, it would take a long time to pass the authorization check, but if you then load RBass it would load quickly. Then if you load, say, CLA Mixdown, it would take a long time, but if you then load CLA Vocals after that, it would be quicker again. I do recall similar delays with Cubase 11, but, as I indicated here, I haven’t done a side-by-side test, so it may well be that the times are significantly longer on my system with Cubase 12.

I will also note that I do see very long load times (depending on the plugins, sometimes even longer than Waves) for NI plugins I’ve been using (on my current project these at least include Kontakt 6, Guitar Rig 6, and Massive X), anything by Arturia, at least some IK plugins (I’ve only tried MODO Bass and AmpliTube 5 on my current project), and perhaps others I’m forgetting. I haven’t noticed long delays with PSP Audioware plugins (they use iLok, though, while all the others mentioned use their own proprietary authorization mechanisms). I haven’t noticed one way or the other with iZotope plugins, but I don’t use very many of those regularly.

Cubase 12.0.10 and 12.0.20 have also been the most unstable versions of Cubase I’ve used, but I only started at 9.5 (and really only was using it consistently from 10.5 forward). However, for the most part, the instability has been the hangs on shutdown, which happens the majority of the time on my system. There have been some other hangs as well, but they are much rarer – certainly not every day, but maybe once or twice a week? The hang on shutdown is extremely annoying, though, because it means that I have to redo Cubase-level changes I’ve made in each session, such as any control room inserts and even MP3 file ID3 tag info when I do exports (it boggles my mind that is a Cubase-level parameter instead of a project level parameter).

1 Like

I have not done a reboot of Windows itself but I quit the respective Cubase version before opening the other one and checked with the Task Manager that the processes were killed. I don’t think that it has anything to do with cached memory as I can repeat replicating the issue within Cubase 12 with every new session I create or open while the programm itself stays open.


  1. Open Cubase 12
  2. Create an empty session
  3. Add an audio track
  4. Add a (specific) Waves/Plugin Alliance plugin to the inserts
  5. Result: >20s loading time, Cubase freezes
  6. Close the session, leave Cubase open
  7. Create another session and repeat from step 3, using the same plugin as before.
  8. Restult: >20s loading time, Cubase freezes

If you do the same in Cubase 11 the issue won’t accure. At least with my Windows 10 system.

So even if it may have something to do with initial resource loading or activation I don’t think it is acceptable. Especially as it is an issue which is introduced new to Cubase 12 for one of the most basic tasks in a DAW, loading insert plugins.

Yes, I also have the hangs/freezes on exit. Around 90 % I need to kill Cubase 12 with the task manager or even if it seems that it has terminated correctly, I get the crash report/save start menu when opening it the next time. I think I already send more than 100 crash dumps to Steinberg. Hopefully they end up somewhere and they fix this mess. At least I still can use Cubase 11 if I need a somewhat stable system.

1 Like

Yeah, the two projects in one session test you outline above should rule out the cached plugin thing I was wondering about. I guess it also indicates that Waves authorizations don’t keep track of that within a single Cubase session – i.e. it must only be done at the project level.

Beyond the hang at shutdown, Cubase 12 has mostly been reasonably stable for me, though not as stable as the last version of 11 was (i.e. I have had a few hangs here and there, but probably a maximum of 1 or 2 a week). And the productivity gains like being able to batch freeze/unfreeze multiple tracks in one go have been a big help on the workflow front, so that tends to make up for the hassles caused by the other issues to some degree – for me, enough so that I haven’t considered going back to 11.

BTW, as a semi-related aside, I had to do some work in Cakewalk by BandLab earlier today, so I thought I’d see how long it was taking for the initial Waves plugin of a given batch to load. It was over a minute! Coming back to Cubase 12.0.20 after that, I’d get a slightly lesser amount of time in the same situation, though, with my current project loaded, most Waves plugins, even ones that were not in the project and were in a bundle other than the Waves plugins that were in my project came up in around 5 seconds. One key exception was Nx Germano Studios, which took just under a minute. I wondered if maybe having loaded some of the others (or ones from their same group) at least once during the history of the project somehow made a difference. Or maybe I was just missing that most all the plugins I tried were in the Diamond Bundle, even if I’m pretty sure that a few I tried that still came up quickly (like CLA Nx and Nx Ocean Way Nashville are not – but I think I had used them in earlier sessions with the same project).

One other thing that came to mind that may possibly be relevant: I recently started using the Steinberg power scheme in Cubase, resetting my default Windows Power scheme to the basic one. In the past I couldn’t use the Steinberg scheme because it reset the basic one after I got out of it, even though I’d been using a high performance scheme from using SONAR/Cakewalk fairly frequently. I only started using the Steinberg one with Cubase 12 since it is now extremely rare for me to use Cakewalk beyond some simple file testing.

Is it possible you are not using the Steinberg power scheme with Cubase 12 but are using it with Cubase 11? If that actually made a difference here (and it might possibly explain why it was very slow in Cakewalk since I didn’t change to a high performance power scheme) that could possibly explain what you are seeing between 11 and 12 because my understanding is having used the Steinberg scheme in 11 does not automatically result in using that scheme in 12. It has to be manually set. (I remember seeing that mentioned in some of the Cubase 12 performance threads.)

1 Like

I took the time today to reinstall all Waves plugins. Also used the “repair” option in Waves Central and cleared the cache. And instead of “System” actication I used a spair USB drive. Solved the problem for me. Will try to do something similar with Plugin Alliance.

1 Like

Interesting. The system activation is using the MAC address of a network adapter. (I learned this from Waves Support once after having my activations disappear after having disabled a network adapter I wasn’t using in hopes of freeing up some system resources. I ended up using the once a year recover licenses feature before learning what had happened.) In my case, the network adapter currently being used by Waves is my Wi-Fi adapter, so maybe communicating with that (or whatever system routines return the MAC address) is a lot slower than with whatever they use to read licenses off a USB drive. I’d updated my Waves software yesterday, prior to having done the testing I mentioned, so I should be current on everything.

If there is indeed a much longer check in Cubase 12 than Cubase 11 (which your testing suggests is the case), perhaps that means Cubase 12 has changed something that slows the connection to checking the MAC address down (but doesn’t affect whatever reads licenses off a USB drive). That might also mean that other authorization checks in this area are also using MAC addresses for the system identifier (which I believe is a common thing as those rarely change in a personal computer).

For my purposes, the long license check time is a fairly minor annoyance in most cases, but it obviously also contributes to the very long project load times (and possibly plugin scan times?). Thankfully, I’m usually working in projects all day, so I load them up once, walk away and do other things, then they’re usually loaded by the time I get back to my computer.

I mean problems and bugs should be sorted out by the vendors, but Cubase should still not crash, even if the plugins crash. Would be nice if you could leave a vote here if you think the same:

Solution to crashes by plugins - Sandboxing (Crash protection) - Cubase - Steinberg Forums

Hi together,

I did some further testing and on my system the problem only occurs when being ONLINE. As soon as I deactivate my network card, all waves and plugin alliance plugins load as expected. So it has to have something to with phoning home for either license checkup or update check etc. besides the fact that I have both, waves and plugin alliance, licences stored locally on a flash drive.

Also, I tested again with Cubase 11 and the problem occurs there as well from time to time.

Steps to replicate the problem:

  1. Make sure you are connected to the internet
  2. Create a new empty session in Cubase
  3. Add an audio track
  4. load a Waves/Plugin Alliance plugin to an insert slot
    Result: Project freezes, plugin load time between 30 to 60 seconds

Then disconnect from the internet and proceed from step 2.
Result: Project does not freeze, plugin loads more or less immediately (1-3 seconds).

As this seems to be plugin vendor specific, I also contacted the Waves and Plugin Alliance support teams.

Hopefully there will be a solution for this.

Hi there.

Found this solution on the Waves Forum: SOLVED: Waves plugins very slow to load - Support - Waves Community Forum :white_check_mark: :white_check_mark: :white_check_mark:

I actually had a network drive which was not mapped when being online, because the system it was detached to was not running. As soon as I have deleted the network drive from the main system the problem was gone. Seems that Waves and PA are scanning all drives somehow when loading a plugin the first time.

Hope this helps others with the same problem.

1 Like

I’m glad you found your solution. Unfortunately, this does not appear to be applicable for my case as I do not have mapped network drives, at least as far as anything I can tell from looking for them the the methods I’ve located to check (e.g. the article at Windows 10 - Finding Mapped Drives).

I do wonder about another Waves-specific strategy mentioned elsewhere in the thread you referred to, but, at least on my system, it is not only Waves initial plugin loads that have this issue, but also NI, Arturia, and possibly some others I’m forgetting.

In my case, there does not seem to be a difference whether I am connected to the internet or not. For example, I just tried putting my system into airplane mode, and timed a first-time Waves plugin load somewhere around 90 seconds.

That said, I also wonder if there is something else somewhere that is “more hidden” (i.e. in the sense of not being visible like mapped network drive should be in File Manager) that could be coming into play across multiple vendors who use similar strategies for licensing checks. It definitely makes conceptual sense that the long times might relate to waiting for some sorts of timeouts when trying to check something that doesn’t actually exist but did at one time.

I know this is old, but for it’s worth: deleting network drives worked for me! I had one VST from Plugin Alliance taking~30 secs. to load in Reaper. Now it loads almost instantly.
The network drives in question were pointing to a device that no longer exists, but remained mapped on my Windows system. I ‘disconnected’ each one from the context menu in Windows Explorer.