(SOLVED) Cubase IC Pro IOS app crashes only recently (Jan 2024)

I’ve been using IC Pro without issue for the last 4 years until just now.
I activate the app on my iPad which as normal opens with the screen waiting for the computer IP to assign which usually happens when Cubase is opened on the computer and the Ski program communicates, then IC Pro usually opens up with the project screen window even before a project is opened.

However, now, as soon as Cubase opens, the IC Pro app crashes. Likewise, if I open Cubase first then open IC Pro, IC Pro tries to open then immediately closes.

I have not updated my Cubase which I’m keeping on 12.0.0 for other bug reasons so it’s not Cubase change related.
However, my iPad has automatic updates set and recently updated to IOS 17.3 which I believe is where the issue lies because my iphone with iPhone IOS 17.3 is able to connect (iPhone & iPad are different IOS profiles).
I just connected a very old iPad2 on IOS 9.3.5 and it works perfectly.

Therefore it must be an Apple ‘iPad IOS’ issue which I believe only Steinberg would have the power to report a bug to carrry any weight with Apple.

Does anyone else have this issue please to help Steinberg push this?
I sorely miss the facilities of IC Pro for remote tracking and general control of Cubsae with macro buttons etc. . :sleepy:

UPDATE! I just rebooted my iPad and it works fine now (HOORAY!). I’ve left this posting live with the solution ticked incase anyone else is searching for this issue.

iC pro is a complete disaster and needs a good update (see other companies) in my case sometimes it doesn’t connect, then it reconnects by itself… other times it doesn’t find the device… I end up using my laptop with remote control and it never fails.

Steinberg has only been updated (if you can call it that) due to certain Apple requirements. Therefore, in this case, thanks to Apple, we are still using IC pro, otherwise it would be Abandonware.

For the record, when it works well, it is gratifying to have it on hand, especially when you are doing the entire process yourself.

To be honest, when I first got it working it has been stable albeit with one main function not working (the search text entry to find shortcut functions) which they fixed about a year ago. Maybe my issue above was purely an unstable iPad that simply needed rebooting.
I love the functionality IC Pro has for such a small price and the range of functions and uses it gives you compared with hardware controllers such as the cue mixes working with control room and ability to use it anywhere that’s on the same wifi network which makes it so versatile for tracking in your own. Credit where credit is due :heart_eyes:

Same issue here with an iPhone with iOS 17.3.1. Once I rebooted, it worked fine. I guess it’s the same old issue with any software…if it doesn’t work, turn it off then on again. :man_shrugging:

1 Like

Hi all,

Please note that Cubase iC Pro 1.2.7 for iOS has been released, which addressed the problem that establishing a connection rendered the app unreliable for some users.

Download Cubase iC Pro on the App Store

Warm greetings,