SOLVED: Cubase Pro 10 won't even start (on Windows 7 64-bit)

Bottom line on top: I needed to install the Windows 7 Platform Update: https://www.microsoft.com/en-us/download/details.aspx?id=36805

Original post:

Hi all,

I just finished installing Cubase 10 Pro (Windows 7 64-bit) and when I launch the app the splash screen comes up for a second or two and then goes away. That’s it. Joy of joys. I tried restarting and I also tried disconnecting/reconnecting the e-Licenser (which has recently been updated w/ the Cubase 10 full license). No dice. The splash screen says “Initializing: eLC” for maybe half a second then “Initializing: Loading GUI Resources…” flashes very quickly before the splash screen goes away. That’s it. Oh, it’s version 10.0.5 apparently.

Apologies if this has been asked already. I tried searching but the results I got were worthless. Would love to at least be able to try Cubase 10 before giving up on its bugs and going back to 8.5 hahaha.

Many thanks in advance!

Brian

Hi Brian,

Maybe this helps: https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/program-installation-does-not-create-a-soft-elicenser.html

Hi,

Make sure your eLCC is up to date, please. Try to start it as Administrator and trigger Maintenance. Can you start Cubase after this?

hi I had problems in win 7 try updating net framework from microsoft

Thanks guys! I ran the eLicenser “maintenance tasks” before adding the new license for Cubase 10, but I’ll try uninstalling that and installing the latest version. And I’ll make sure to update the .NET framework too. I’m at my day job now (womp womp) so will try these things tonight.

Thanks all!

Brian

Okay, I just got home and:

  • uninstalled the eLicenser Control Center
  • installed the latest Microsoft .NET Framework (4.7.2)
  • installed the latest version of eLicenser Control Center

Then I tried launching Cubase Pro 10 again. Does the same thing. Splash screen comes up for a sec, then goes away. Nothing else.

Any other ideas? I’m realizing I should have posted this in the “Issues” forum… Moderators, if you’re listening, can you move it for me? If appropriate.

Many thanks,

Brian

https://www.microsoft.com/en-us/download/details.aspx?id=36805

Try installing this.

The Platform Update For Windows 7 did it! Cubase 10 is up and running now. Many thanks all! I’ll update my original post.

Hello everybody
Im having a similar problem

I bought cubase pro 10 last week , im have format my pc , with windowns 7 ultimate 64 bits and install all the drivers

Affter instal cubase, it wont open, apear a error like this -> procedure entry point could not be located in the dynamic link library DGI 32.DLL

I have tried all sorts of updates and Dlls and drivers that have seen and read …but now i read this “cubase 9.5 features a new graphics sub-system that seems to show incompatibilities with certain NVIDIA graphics processing units (GPU) and driver versions.”

in this article
https://helpcenter.steinberg.de/hc/en-us/articles/115001841510-Windows-Cubase-9-5-does-not-start-or-crashes

Well mine version of cubase is 10 but i have have a nvida graphic card.Is this the problem ? i have desactived the graphic card and still gives me the same error…

Anyone have some ideias ?

Thank you

helpppp

Hi,

Maybe this kind of article could help.

Had the same problem and Win Update helped, thanks!

I was having all sorts of CPU issues running 10.5 on W 10 so I popped my W7 drive back in my HP Z800 dual hex cor Xeon and installed 10.5 in and it works! The cpu doesnt spike now and the overall hit on the ASIO meter as well as the cpu hit showing in the task manager are both lower. It might be that the driver for my MOTU 424 card is from 2012 and they havent done a dedicated W10 driver but Im not gonna replace that system as it would be way too expensive to get a new 96in and out audio set up just so I can maybe solve this issue with W 10. I used Cubase 5.6 for years before upgrading to Cubase 10 so Im happily stuck with 10.5 for the foreseeable.