[SOLVED] Cubasis 2.2 - Big Midi recording problem

In Cubasis 2.2, it seems whenever I arm a Midi track with an instrument (internal or interapp)

  • this instrument can be played from my controller keyboard in Cubasis
  • BUT: as soon as I start recording to the track, the instrument loses midi connection from the controller keyboard immediately, every time, and nothing is recorded to that track
  • only a disconnect of the USB/camera-kit connection and reconnect brings midi back to life

Could others please verify?

  • Open Cubasis
  • add a midi track
  • arm it with an internal or interapp piano, epiano or synth
  • play the instrument from your controller keyboard with proper midi connection
  • now click metronome and record buttons and begin to record
  • do you still hear any note or get anything recorded?

To be sure, I tried the same controller keyboard connection with Cubasis 2.1 on my other iPad: there recording by using the same controller keyboard connection works without any problems.

Is this a heavy bug introduced with 2.2, making normal recording impossible altogether?

Hi jimknopf,

Gave the issue a quick check:

  • Connect CME Xkey keyboard with Cubasis via BT
  • Add two MIDI tracks and assign them to Classic Machines and an external Audio Unit app
  • Activate Metronome and record a few MIDI events

Result:
MIDI recording works as expected in both cases.

Best,
Lars

OK, very weird:

to check the issue I connected my Prophet 6 via USB, instead of my Korg Microkey Air, and all works as expected.

With my Microkey Air, connected with USB, I still get the issue exactly as described:

  • it works flawlessly recording with Cubasis 2.1
  • the connection immediately stops working each time, as soon as midi recording begins within Cubasis 2.2

I’m not glad at all that my leightweight setup, which worked well with Cubasis so far and was bought exactly for that configuration (iPad Pro 12.9’’ plus leightweight keyboard as portable solution), does not work any more. The Prophet 6, part of my home studio for Cubase recording, is no akku or usb based portable solution and can’t replace my Microkey Air as controller keyboard for the iPad.

There must be a reason why Cubasis 2.1 worked and still works with my Microkey Air via USB, but Cubasis 2.2 doesn’t. I’m already very disappointed, that the very urgent Midi out issue (sending only to channel 1) has not been fixed. But now effectively making my main iPad controller keyboard useless with the new version seems a bit much to me.

P.S. Strange enough, the Microkey connection works over bluetooth (which I don’t use due to the usual Bluetooth slight latency issues), but not over USB. I tried different cables, have reset the iPad, whatever: no way.

I would be interested if the above connection with your CME controller keyboard works just as well recording midi with USB conncetion as with Bluetooth, Lars.

Hi jimknopf,

The Cubasis 2.2 update did not introduce changes in that area, also our quick checks and your testing result using the Prophet 6 device did show expected behaviour. So I’d assume the problem is related to the Korg Mickey Air.

Unfortunately we’re not equipped with the Korg Microkey Air device, so I suggest to get in touch with Korg regarding the topic. If required I’m able to have Korg equipped with a Cubasis promo code.

Hope that helps.

Best,
Lars

How can the problem be connected to the Microkey Air, when it has been working fine (and still does) with Cubasis 2.1, but not with 2.2, on the very same device? I’m curious for any explanation making that plausible. :wink:

So what should Korg change, if the Microkey Air has been working fine with ANY hardware/software setting I have used so far, including my iPad Pro with Cubasis 2.1, with the ONLY exception of using Cubasis 2.2? As long as there is no plausible explanation for that difference, your proposal must sound like premature responsibility shifting to me.

Hi jimknopf,

As stated before no changes took place in that area between 2.1 and 2.2.

Also we have not been able to reproduce the issue at our end, neither using BT-capable devices or keyboards connected via cable.

Please give it a try to shut off and restart the iPad and re-activate Bluetooth to see if it helps to solve the issue.

If the problem persists, please get in touch with Korg regarding the topic.
I am able to have them equipped with a promo code.

Best,
Lars

Hi Lars,

I have already tried resetting my iPadPro 12.9’’: that doesn’t change anything.

Bluetooth Midi is no option for me, because I find the wireless latency quite disturbing, all the more in connection with mini-keys. I would only use bluetooth for very simple quantisized recording jobs (simple drum patterns etc.), not for instrument playing and recording.

So I have to rely on the USB connection. This works flawlessly with Cubasis 2.1, as I said, but not with 2.2, for whatever reason. I simply don’t have the time and nerves to find out why: I just want to record.

Is there any way to reinstall Cubasis 2.1 on my iPad Pro 12,9’’? This seems the only option left for me. I have already had enough frustration trying to work around the midi out bug, and wasting too much time for that.

As long as that is not cured, I can only do very basic idea/sketch recording in Cubasis anyways, and not work properly with the app. 2.1 would serve that very limited purpose well enough. For anything even halfway serious, I have returned to using Cubase 9 Pro on a music notebook, despite the unwelcome weight. The iPadPro/Cubasis solution, which had fascinated me from the start, just has not worked out as well as I hoped, and instead has introduced too much frustration for my purposes lately. Maybe I will have a new look at the app for halfway serious recording in a year or two.

So, any chance to downgrade to 2.1?

Hi jimknopf,

Unfortunately I’m not aware of an official way to revert to a previous app version.

Did you already try turning off “Bluetooth/Airplay” in the Setup/Audio section?
Additionally, it might make sense to give a Cubasis re-install a try. In this case, please make sure to backup all your files first properly.

Hope this helps to solve the issue.

Best,
Lars

A complete uninstall and reinstall, after a complete data backup, solved the issue.

Big relief on my side, to be able to use my iPadPro for Cubasis recording with my leightweight controller keyboard at all any more.

Please feel free to mark this issue as solved or delete the thread.

Hi jimknopf,

Thanks for the update.
I’m glad to hear that a fresh install of Cubasis 2.2 helped to solve the issue.

Best wishes,
Lars