[SOLVED] Cubasis + AU playing multiple keys issue


I am using the latest version of Cubasis and have been using a few AU3 apps such as Virsyn’s AudioLayer and Beathawk as instruments within Cubasis and am finding that when I load the instruments up in Cubasis and start playing, that for some reason, multiple keys are played at the same time.
So for exampe, when I load AudioLayer into Cubasis, I am looking a tthe instrument and the Cubasis keyboard. If I play C1, C#1 also plays simultaneously. the same for E1 as F1 also plays at the same time.

I have tried these same instruments in other AU3 hosts and this is not happening.

Is this a bug, or known limitation of Cubasis as I cannot seem to find previous issues discussing this.

Hi fotizimo,

Thanks for your message.
Of course, only the actual note triggered should be played.

Please give it a try to deactivate multiple gestures (General/Multitasking & Dock/Gestures) in the iOS setup, to check if this solves the issue.
Additionally, it might make sense to enable “Arm Selected Track” (Setup/Arranger) as well.

Please let me know if this helps to solve the issue.


Hey there Lars,

Thanks for getting back to me, but I have checked both settings, and neither of them resolves the issue. So to be more clear:

Cubasis will incorreclty play multiple keys only for certain AU instruments. So if I load Synthmaster One, iSem, BeatHawk, and AudioLayer into the same project, there are no issues with SM1 or iSem, but BeatHawk and AudioLayer play multiple keys, up and down the keyboard. If I load any/all of these instruments into any other IOS DAW, I have no problems with any of them, so far only BeatHawk and AudioLayer when used with Cubasis.

Actually, I was just trying this with a physical keyboard, and when I load AudioLayer into a project on its own and show the Cubasis keyboard on the screen, when I play C1 on the keyboard, it shows me playing C1. When I play C#1, it shows me playing D1, doesn’t play the note associated with C#1 but instead plays the note associated with D1, and C#1 isn’t shown as being played at all. Playing D1 plays the correct note and shows D1 as being played. D#1 seems to be correct as well. Playing E1 shows F1 as being played and also plays the note associated with F1, while not showing E1 being played in Cubasis. F#1 and A1 also plays incorrectly, and this pattern goes all the way up or further down the keyboard range.

I can replicate this very easily, is there a way I can capture this and send the information along?

Ok, I am a fool.

So I started trying to figure out why this was happening, and it occurred to me that it was only happening on the Beathawk and AudioLayer channels I had created. So I decided to change the AudioLayer Au for a different one (but keeping the same track/channel) and realized the problem was happening for that AU instrument as well.

I decided to look at the channel settings, and I found out I had left a midi insert called Rozeta Scaler on those two channels, and they were scaling all input to a major scale. I had completely forgotten that I had left that enabled, and since it was the first midi insert I had ever used, it never occurred to me to look there.

Disabling the insert removes all problems and Cubasis is working as expected. I will leave this up as a testimate to my forgetfulness, and hopefully help someone in the future.

Thanks for the quick response Lars!

Hi fotizimo,

Thanks for your feedback and clarification.
Glad to hear that there is no problem.

Will close the topic as solved.