[SOLVED] Cubasis problems!!

I recently stopped using my tried and trusted mobile recording rig consisting of Logic Pro, MacBook Pro and Neve 1073 DPD in order to streamline my setup as the amount of gear I needed to record with one microphone was ridiculous!

I moved to a setup with Cubasis 1.8.3 on an iPad 4 and an Apogee Duet which is amazing as I have much less gear to cart around.

The problem is, Cubasis has been a bit of a nightmare when it comes to recording. On numerous occasions, whilst recording I have accidentally touched another track when trying to change the volume of the selected track. Cubasis then starts recording on the track you accidentally touched!! This also means you can’t change the monitor mix during recording as it starts recording on any track/fader you touch. Completely unacceptable. There should be a preference to lock the record enabled track.

I also need a way to monitor reverb properly whilst hearing the zero latency input from the Apogee Duet. I’ve had clicks and pops with buffer sizes lower than 256 which is too high for vocals monitoring through Cubasis. What is the best way of doing this? I’ve tried various ways including using a send in Cubasis to an inter app audio reverb (ad480) which every now and again drops connection for some reason. I’ve also tried putting a reverb on the track insert in Cubasis (set to 100% wet) and balanced the software return in the duet mixer with the live input but these are not great solutions. If anybody can help, it would be much appreciated!

Try going to “setup”-then “arranger” and make sure “arm selected track” is turned off-it automatically arms a track as soon as you select it-not sure why that would be useful,maybe for people quickly getting ideas down and want to get recording ASAP-I find it a pain in the butt and always turn it off-persevere with cubasis-i still thinks it’s a great IOS DAW-good luck

Thanks, will try that. Not sure how I missed that setting!

Hi djrustycans,

I’ve posted you a PM since I’ve disagree with the title used for this topic.

Thanks to rossf your question has been answered immediately.
The wording you’ve chosen for title of this topic is misleading and might confuse others who reads it.



Thanks for changing the topic title, appreciated!