[SOLVED] Cubasis RoomWorks SE?

I have purchased and installed Cubasis 2.2 on my iPad. Purchased and installed all available addons. It continues to remind me to get RoomWorks SE for free if I register. I click the [Free] button. It takes me to a login page. I log in. It takes me to My Products where I see Cubasis 2 listed. Indicates product activated. Where and how do I get RoomWorks?

Hi EnjoyRC,

Some users already have reported that there are problems with the registration of Cubasis with the outcome of unlocking RoomWorks SE.
The next Cubasis update will be released very soon and addresses the issue.

Sorry for the inconvenience.

Best,
Lars

Thanks Lars. Looking forward to it.

Promised, it will not be long…

Best,
Lars

Hi all,

Please note that the latest Cubasis update, version 2.3 is available.
This update also addresses the Room Works SE registration issue.

https://www.steinberg.net/forums/viewtopic.php?f=183&t=126990

Best,
Lars

Cubasis 3.4.3 for Android is not registering RoomWorks SE.

Description:

  1. The app Cubasis 3.4.3 is opened on the Android tablet.
  2. The current song that is loaded displays the message stating that RoomWorks SE is not available.
  3. I then press the shop icon at the upper right hand corner of the program.
  4. A message is then displayed stating “You will be automatically redirected to the target page. If you aren’t forwarded to the new page click here.”

Expected Results:
I expect to be taken the Steinberg login site so that RoomWorks SE can be registered.

Actual Results:
Nothing happens and the page displaying the message does not change.

Environment:
Samsung Galaxy S7+, Android OS 12, Cubasis 3.4.3.

1 Like

Same for me, i registered and only get blank page

for the record, here too
page 404

somebody suggested elsewhere having had success after having acquired one of the paying bundles offered up on the same platform. If there is no support reply I might try that even though none of the offered packs really speaks to me.

Yes i was trying to get roomworks and it wouldnt register within in the app so i gave up…
Then later i bought some of the dlcs and thought to check roomworks again
Clicked on the button and had instantly connection, no redirects or error messages.

So it seems some of authentication procedure is blocked/locked untill you buy one of the DLCs

Im on a tab s7, android 12 and the latest cubasis

1 Like

Greasy…

Its has been fixed in the mean time

1 Like

Hi @CJ_Monster,

Thanks for your message.

Many of our users were confronted with the issue, that registering Cubasis to receive the free RoomWorks SE plug-in has failed.

After evaluated the topic, we’ve found out that an accidental change in the data format caused the problem, which has been solved by our digital unit department a while ago.

We apologize for the inconvenience.

Thanks,
Lars