[solved] deleting triplets after filtering

hello,

I have some triplets, I filtered the upper notes

and deleted them all at the same time. This is the result…

When I delete them one by one the structure says intact.

[edit] I can not deselect the 3s after having filtered the upper chord notes.
intact.png
result after deleting upper notes.png
triplets selection.png

when you select, avoid selecting the “3” in the tuplets

SW

SeeWhat, I have filtered the triplets, see here:

https://www.dropbox.com/s/0rsmhixzub8ymj6/delete%20top%20triplets.mov?dl=0

there is no way I can afterwards deselect the 3s…

… only by selecting note for note with the mouse does work …

[Edit] I found the correct way to get the right result:

https://www.dropbox.com/s/e881yrfs2tzlhpm/found%20a%20way%20in%20three%20steps.mov?dl=0

Filtering top note, switching filter to Deselect Only, filtering tuplets, then delete :slight_smile:

Yes, I am finding out the order in which you call the filtering option among the other steps affects whether it works properly or not. For me, this is still often trial and error, which I hope will improve as I gain more familiarity with it.

thanks
this will be a great macro candidate

SW

k_b writes:

there is no way I can afterwards deselect the 3s…

Yes, you can, just control-click (command-click on Mac) each “3” to deselect triplet numbers. (Zooming in close helps to precisely click on the thicker elements of the "3"s.)

musicmaven, no you can’t :slight_smile:
at least not after the triplets have been selected by filtering
Even if you have only filtered one tuplet/triplet, the 3 can’t be deselected with control-click (command-click on Mac).

It works on my computer. Just to make sure I am understanding your workflow: I have a measure of triplets with 2 notes on each stem. I selected the notes which shows all notes and the “3”'s as being highlighted. I filtered the top note in chord, then I deselected the “3”'s by command-clicking each one separately. Then I pressed delete and the top notes were deleted with remaining lower pitches as triplets.

https://www.dropbox.com/s/dancw5mtnefecps/3deletionmovie.mov?dl=0


Another way around the whole issue is to use a marquee selection technique and draw a selection around the notes only (without the "3"s selected). Then you can proceed by filtering the top notes for deletion as shown here:

https://www.dropbox.com/s/2syt2s2mjunwvsl/marquee.mov?dl=0

musicmaven,
that is interesting, all your suggestions do work, except the first one (your first screen recording).
The only difference I can think of is, that I am on macOS… Here deselecting does not work after filtering like in your example…

Hey k_b, I’m on Mac too. It really helps if you zoom in (which I did not show). If you zoom in a ridiculous amount, I bet you will be able to click in the right spot to take effect - which for me is the largest part of the 3. Since my screen recording does not show my keystrokes or clicks, you could not see that for two of the attempts, it took 2 tries (clicks) because the first click missed the “3”.

musicmaven, you are right :slight_smile:
I zoomed in - and I could deselect them one by one.
So no more mysteries - good thing!

Glad it’s working for you! :slight_smile: