SOLVED - digital piano incompatible with HSO ?

my new digital piano roland fp-7f sends note off velocity data to cubase which lead to an unwanted and messy (note-off) sound at the end of each sound when releasing the keys, especially when i want to play fast string-phrases.
this effect is very annoying and makes working with halion symphonic orchestra more or less impossible.
i know that AFTER RECORDING i can set all the note-off valus to zero in the list-editor, but i want to have that already from beginning when playing the keyboard while recording into cubase.
Is there a way to block or filter those incoming note-off velocity data from reaching cubase and HSO at all? I did not have this problem with my old input-keyboard (Ensoniq ESQ-1).
Thanks for advice! (CUBASE Studio 5.5.3)

Many keyboards send a note on with zero velocity rather than a note off … the problem is Cubase only has the concept of a “note” event type and a duration. There’s no way to my knowledge therefore to filter only note-off events in realtime within Cubase. You would have to use a combination of something like MIDI-OX and a virtual MIDI cable.

Perhaps your keyboard has a setting where you can change what it sends? As it’s a piano rather than a MIDI master keyboard, the setting might not be obvious … look for a setting something like hammer noise, or resonance, try setting that to zero and see if it makes any difference. MIDI-OX is a useful tool for such diagnostics, but it’s PC only.

I believe you can use the input transformer to filter the messages.


Thanks a lot, that is it. problem solved. :slight_smile:

Do you mean you were able to use the Input Transformer to filter only note-off velocity?

exactly; in the input transformer i did the following:

  1. i set function to “transform”
  2. in the upper area i chose “value 3” (= note off velocity, see list editor) to “bigger or equal” and as parameter 1 i
    set “0”.
  3. in the lower area again i chose “value3” , then “divided by” and “3.000” (parameter 1). that reduces the noteoff
    velocity into a range where it does not trigger that unwanted noteoff sound anymore. certainly one can experiment
    with different values for parameter 1 in the lower area. for my needs “3.000” workes good .
  4. in the upper right side of the track inspector (on left side of arrange window) there is a button with a kind of a
    snake arrow. there i chose “local” (= only applies to the current track). i did this on every track where i wanted to
    have reduced noteoff velocity.
  5. Voila :slight_smile: !

Thanks for the details, but won’t that just divide all velocity values by three, including note on velocity. Value 3 is velocity, not just note-off velocity.

i don´t have any loss in note-on velocity, just the desired reduction in note-off velocity.

in Cubase Studio value 3 is just note-off velocity!

that´s a fact, see list editor:
value 1 = note
value 2 = note-on velocity
value 3 = note-off velocity

:bulb: Aha! Brain freeze on my part … I was thinking about MIDI messages, i.e. 0x90 note on, channel 1 and 0x80 note off, channel 1, where the 2nd byte of the message is pitch and the 3rd byte is velocity. Must RTFM a little more closely! Thanks again for your explanation.


I noticed this in the release notes for Cubase 6.0.3: :slight_smile:
28627 Input Transformer: The “Off Velocity” parameter has been added to the Input Transformer.