[solved] Don't install 9.5.50 if you use VST3 plugins!!!

Steinberg has released some remarkably bad updates in the past, but this one may be the worst!

Version 9.5.50 fails to detect all of my (numerous) VST3 plugins! WTF?!? Is this SB’s way of indicating that they’re phasing out VST3?

Is anyone actually looking at these updates before they’re released? How can functionality as vital as VST3 support be missed? I’m truly astonished.

Save yourself the pain and skip this one until they resolve this latest careless blunder in a long series of careless blunders. Geessh.

No that problem here

Here neither.

C9.5.50 working perfectly for all VSTs of all versions here.

I only use VST3… Unless this is a new update today that i don’t know about, VST3 all fine.

After uninstalling C9.5 Pro (apparently there is no way to just roll back the update itself), reinstalling C9.5 Pro, and then updating it to 9.5.41, all of my plugins (including VST3) are functioning again. So, at least for me, the problem was clearly 9.5.50.

This must be Steinberg’s plan: release an update that breaks existing functionality so that when you reinstall your previous version you appreciate it more, despite its many flaws, becasue at least it’s better than the new version. Very clever.

To much coffee me thinks…

Actually, not enough. :slight_smile:

46 hrs studio pc powered on with opened cubase large session (VST2,VSTi2,VST3,VSTi3)
9.5.50 no problems so far.

Control Panel -> Programs and Features -> View installed updates (top left-hand side) and then you can select just the Cubase update you want to remove.

I just switched from Windows 7 to 10 and recall being able to select the updates in Control Panel > Programs (what’s now called Programs and Features).

So, thanks for your post.

I’ve been very lucky with plugins up till now, so I’m not sure why 9.5.50 didn’t detect any of my VST3 plugins.

Fortunately rolling back to 9.5.41 fixed everything. I guess that’s where I’ll stay.

I would not consider it “solved” if your Pro version of CB 9.5.50 is not recognizing VST3 plugins. Now that you know the procedure to easily uninstall the update you should give it another shot. It is possible that the installer somehow missed the VST3 location.

Regards :sunglasses:

Hey Prock, I actually did try installing 9.5.50 several times including from a complete reinstall of the full (~9GB) installer, deleting the entire settings folder, updating Windows 10, rebooting, etc. And for every attempt the same exact thing happened – Cubase failed to recognize all of my VST3 plugins.

Thus, I definitely do not consider this solved.

But no worries, I no longer start new projects in Cubase (I switched DAWs last year). At this point I just use Cubase to edit old projects that I didn’t convert over to my new DAW.

Cheers…