[SOLVED] Dorico 3 with Noteperformer 3 - no playback

[EDIT: Solved -

PaulWalmsley: Can you go to Edit > Device Setup and re-select your current audio device and set the sample rate, then try again.

Did this, restarted Dorico, all was well]


Hi there,

Newly installed Dorico 3 and Noteperformer 3 on Mac (OS 10.12.6). Playback head not moving on on playback. Editing Noteperformer (i.e. pressing the “e” button in the VST Window in Play) comes up with the instructions on how to setup Noteperfomer (screen shot attached) instead of the channel window. Having gone through these instructions this still appears. Trying playback after this caused Dorico 3 to crash (crash log attached).

Any advice? I’ve gone through the ZIP file that DS posted for the playback template fix.

Cheers!

Rich


com.apple.preferences.icloud.remoteservice_2019-09-21-200652_Richards-MacBook-Pro.crash (113 KB)

Having followed Daniel’s instructions, are you now trying a new project or an old project? If you go into Play mode, and then go Play > Playback Template, does NotePerformer appear there? Is it selected? What happens if you select it again, hit Apply and close, then try playback again?

Hi Leo,

  • New project
  • Yes NotePerformer appears
  • Yes it’s selected
  • Trying playback again crashes Dorico 3.

Here’s a video just to show you:
https://youtu.be/UO-rW2vA-eE

Cheers!

Rich

Firstly, slight technical point - it’s a hang rather than a crash (hang = spinning beachball, app is unresponsive, crash = application disappears). This is an important distinction just so we can better work out what’s going on (and the crash log you enclosed is actually for iCloud rather than Dorico).

This appears to be very similar to a known issue. Can you go to Edit > Device Setup and re-select your current audio device and set the sample rate, then try again.

Crash/Hang/wrong log - SO SORRY! I just copied/pasted from where I was told logs would be, apologies! Thanks for the definiton, will be more aware in future.

Having tried that the Playhead now moves but there’s no audio being output. I’ve tried with sample rates of 44.1k & 48k but to no avail.

https://youtu.be/WAI_r3FF2zA

As a side note (which I hope doesn’t impact on anything), I specifically haven’t downloaded the Dorico Sounds Installer as I was hoping NotePerfomer could take care of everything. Should that have any impact?

Thanks,

Rich

In addition to changing the sample rate, have you tried any of the other settings in the Device Setup dialog, in terms of different outputs and potentially even different devices? The playback troubleshooting video is quite helpful in this regard, especially the chunk from around 12:00 to 14:00:

YouTube

This is quite an odd one - I haven’t seen anyone with the symptoms that you are experiencing. A couple of things:

  • Changing the playback template in the Preferences doesn’t make any changes to the project. It just sets the preference for the default playback template when you create or import a new project
  • I would expect that the NotePerformer window should show a mixer with the sounds that are loaded. It shouldn’t be necessary to turn it on or off in the rack. The fact that it’s still showing the welcome screen suggests that it hasn’t been able to load its own sounds.

Because of this strange behaviour, it’s making me think that the NP configuration files are not correctly installed. Could you check the contents? In the folder /Library/Application Support/Steinberg you should have ‘Dorico 3’ folder, and within that ‘PlaybackTemplateGenerators’ and ‘PluginPresetLibraries’.

[SOLVED]

Do tell…

OH I’m sorry, I wrote a post which then didn’t post…

After going through Paul’s suggestions I then reset Dorico (which I was sure I had done but evidently hadn’t) and behaviour resumed as expected.

Huge thanks to all for you help!

Rich

(Have added the solved explanation to the top post as I couldn’t work out how to change the Post title to include [SOLVED] )

OT: (@rjackson87, You can use the Edit (pencil) one your first message of the thread and then just change the text in the Subject Line box.)

Great, have edited. Thank you!

Hi,
I have a similar problem. Unfortunately the fix that helped the original poster didn’t change anything in my case. I’m on Mac too with Catalina 10.15.5. installed. I’m working with the latest version of Dorico Elements 3.1.10.1032.
Actually no sounds work at all with Dorico. Even the Halion SE sounds don’t work.
Any idea what the problem could be?
Cheers
Kim-Dirk

Please create a piano project from template and enter a handful of notes, then do Help > Create Diagnostics Report.
That creates silently a zip file on your desktop, please attach it here. Thanks

Hi,
ok, there you go. I created the zip file and attached it. Hope there are enough notes in it.
Thanks for the help!
Dorico Diagnostics.zip (1.53 MB)

Thanks very much for the data, but looking through, I can’t find anything unusual. Your project is set up to play out to your M2 device. If that is not what you are expecting, go to Edit > Device Setup and change the ASIO driver.
And what if you change the playback template over to HALion Sonic SE, also no playback?
Furthermore, does the green playback line move when you hit Play?

Unfortunately no. No sounds, both with Noteperformer and Halion Sonic SE. The green playback line works.
Cubase and all my other programs who use the same Asio driver work without problems.
No idea what the problem is.

The Asio driver is the correct one. The M2 by Motu.

Very strange. If you open the NotePerformer editor window, in the left top corner is a little “red LED” that shall flash each time it receives a MIDI note. Does it flash when you play back?
Also the Mixer in the NotePerformer window shall show then some flickering metering. Is that doing?
And then please turn to Dorico’s mixer page, does that one show any metering during playback, especially on the master channel?