[solved?]Dorico no longer producing audio

This has probably been covered in the forum before but I’m too frustrated to do a proper search. The file I’m working on played fine this morning but tonight no sound is produced (NotePerformer). I’m working on an iMac Pro with 64 gigs of RAM and Monterey. I’ve tried resetting the playback template, changing to Halion, and then back to NotePerformer but the file will not playback. I’m at my wit’s end. What should I send to Steinberg that might reveal what’s going on?

So restarting Dorico results in a return of the audio. Unclear why this should be the case. What is going on that launching Dorico, opening a previously functional file that then malfunctions, then closing Dorico, and repeating this behavior should result in a resolution is frustrating and not very satisfying (as a solution).

Do you continue to ‘lose’ audio if you once more relaunch Dorico?

Or did that one relaunch perhaps cure everything?

If not, does it happen with other files?

Does NotePerformer’s visual display suggest that sound is being produced?

Unclear about the relaunch and whether everything is ‘cured’. Since it’s unclear what caused the problem it’s unclear that the solution is ‘the solution’. I haven’t tried it with other files. That’s something I will end up doing when my fortitude for whatever happens is up to it. As far as NotePerformer’s visual display’ - yes, the NotePerformer splash screen popped up when I opened the affected file (that at first didn’t play). It’s all very confusing and mystifying. I’m sure there is a rational explanation but at this point, it’s all “Blair Witch Project”.

If you now relaunch Dorico, does the file play?

If so, that may suggest it was a temporary ‘oddity’ due to some other device or circumstance.

If not, are the sliding faders in NotePerformer active with an otherwise silent file?

Hi Mark,

see below:

I agree that it’s always better to know what caused something.

But there are times when the real cause is just some setting one forgets, or another audio device which is no longer connected.

If you can now reliably quit Dorico and relaunch it and each one of your files play, then - perhaps - it just has to be accepted.

I myself sometimes encounter a problem in my daily work where I am restarting Dorico via the debugger, which means that the audio engine doesn’t quit, and instead keeps running. When Dorico starts up again, it finds the running audio engine and reconnects to that. However, at that point, I never get any audio output from Dorico. To restore audio, I have to quit Dorico cleanly (so that the audio engine also quits), or manually quit the audio engine, then restart Dorico again.

Obviously this kind of situation shouldn’t occur on your computer because it shouldn’t be possible for you to restart Dorico without the audio engine closing and being reopened, but perhaps somehow that is what’s happening.

If you encounter this situation again, I would recommend quitting Dorico, then checking in Activity Monitor that the VST Audio Engine process has also ended; if not, then quit it. Then restart Dorico and I would expect audio to be restored.

1 Like

Thanks, Daniel, I will try that. Recently on my M1 laptop, I encountered something that might be similar where Dorico wouldn’t play the Halion sounds in native mode.

Hi @tbabcock123 , could you please also do Help > Create Diagnostics Report and post the zip file here? It may contain crash files of the audio engine (a crashed audio engine could also explain the odd behaviour you experienced.) Thanks

Dorico Diagnostics.zip (1.5 MB)