[SOLVED] Dorico just crashes in macOS Sierra

Hello - I installed Dorico yesterday on my iMac with macS Sierra 10.12.1. At first, I could run Dorico and I imported a XML-File made with Sibelius 8.4.x. I closed Dorico and after opening it again, I tried to make a new file with a brass quintet template and Dorico hanged. I tried it some times again and could open another template - i.e. 4part choir - but when trying to input music via double click on the first rest, Dorico hanged again. Since today, Dorico refuses to open at all. Any advice? Thanks and regards, Michael

Day 3 after buying and installing Dorico - still not able to do anything with it: on my iMac 5K with macOS Sierra it cannot be startet at all: after clicking the icon, it bounces endlessly and never starts up. No help in sight. Sad.

I’m sorry you’ve not yet had any help. Have you tried contacting support? I have been travelling and in meetings since yesterday morning and have been unable to keep up with everything going on in the forum here.

The first thing I would try is to remove the Dorico folder from /Users/username/Library/Application Support/Steinberg, and also remove the VSTAudioEngine folder from /Users/username/Library/Preferences, then try starting Dorico again. This should effectively reset things back to their default state and hopefully the program will run now. If not, let me know. I’m travelling back to London today but will try to get back to the forum as soon as I can.

Hi Daniel - first: congratulations to the start of Dorico - good to see having finally a follower to Sibelius with promising feature set!
I tried what you suggested - but: still the Dorico Icon in the Dock only bounces endlessly and no start of it then.
Thanks for your help and take care! Have a good trip - regards, Michael

Can you find the file application.log inside ~/Library/Application Support/Steinberg/Dorico and attach it here? You will probably have to zip it up first. The ~ in the path above, by the way, refers to your user folder: you can paste the path above into the Finder Go to Folder dialog (Cmd-Shift-G in the Finder).

No problem finding the application.log-file - it is attached here. It is quite small.

MK
application.log.zip (358 Bytes)

True, not much in there.
Could you please have a look in the Activity Monitor, when Dorico is spinning endlessly, is the ‘VST Audio Engine’ process running. Should appear in the list of running processes. If it doesn’t, then that means that the audio engine dies during startup.

Thanks - I did lookup the activity monitor: indeed, there ist no VST Audio Engine Process running. I attached the Activity Monitor analysis file from Dorico for further investigation.
Analyse von „Dorico“.zip (13.9 KB)

Okay, then it is clear, the audio engine crashes and Dorico is waiting endlessly for it.
But in that case the analysis of Dorico doesn’t help us. It would be best if we could get the crash report of the audio engine.
Because it is a process in the background and without UI, the operating system won’t show you the usual alert and crash report for it. But I’m sure it still logs it in the Console application. Could you please have a look?

The only thing I find under the „Diagnosis and User Data“ in console is the enclosed screenshot.

Really, nothing else? When I open the Console application and then in the left column click on DiagnosticReports, I see all sorts of crash reports from the past. Among them also from the VST Audio Engine. Isn’t there anything with you?

Obviously, that changed a little in macOS Sierra. I enclose a screenshot of my console. Please check.

And how about “Benutzerberichte”? Is there something from the VSTAudioEngine?

Only 1 entry, not related to either Dorico nor VST (is Private Framework)

I noticed another glitch (see attachment) - perhaps here anything went wrong?

This is all strange…
I have a MacMini here with Sierra on it and all is working fine, so I suppose it is not a Sierra specific issue.

For the eLicenser Control Error, you might want to reinstall the eLicenser Control Center.
If you don’t want to reinstall whole Dorico, you can get just the eLC installer from here:
http://www.steinberg.net/en/company/technologies/elicenser.html

Thank you. Indeed, anything with the elicenser went wrong during my initial installation. I installed the elicenser once again, die initial license number was still there and now Dorico runs like charm. As far as I see no further problems for the time being.
Thanks for your help. Best Regards to Daniel
Michael

I’m really glad you’re up and running now, Michael. I hope you find things progressing a little more smoothly now.

Thanks, Daniel. Here is a lot to learn - especially if you come from Sibelius. :slight_smile: But even with the first steps I get excited: f.e. it is a great idea to input via popup dynamics with pp<f in one step. And there is lots more…
Michael