(Solved) Elements 7 FX sends - How do I ?

Hey everyone,
Been a while since i’ve used cubase. And im trying to get back into things with elements 7. I’m sure I will have many hiccups along the way but for now my first headache is the FX sends.
I cannot for the life of me get them working. Ive tried adding FX tracks and selecting, say Roomworks SE. But all I get is a Channel Settings screen with no sign, or way of accessing the roomworks vst.
I’ve also tried to add one via the mix console: Channel Racks but get no option to add an effect when i click on the sends text.
As a side thought I’ve just tried the same with inserts and I’m in the same boat. I’m starting to think there may be an issue with my install? surely adding inserts and sends cannot be so different from old versions of cubase ? I would of though from fumbling around I would of stumbled on how to do it by now ?
Any pointers greatly received !
Jim

Click on the Inserts button and it will expand and give you the bay slots.
Click on one and get list of fx.

Sends-button expand in the same way. On the right side give you a menu where to send.

Is this what you wanted to know?

TIP! I find the FX channels useless since they only send to hardware outs.
Use group channels and you can send anywhere and you still have inserts.

Cheers Larioso,
Unfortunately clicking the inserts expands slightly but provides no bays :frowning: which leads me to believe I have a corrupt install :/. See attached photo. In the mixer i have clicked insets and it expands very slightly and shows no slots for inserts and to the left of the image I have selected inserts. It has fully extended but again no slots :frowning:

Thanks again
Jim

Try inspector which was visible in first screenshot to the left.
Click in middle of button - not to the right.

The mixer bays have default to autosize, and nothing these means no slots.
But you can drag with mouse to expand and then set to fixed,

There is nothing wrong with installation.

Try operation manual to get aquanted a bit.

Sorry, that’s what I meant by the area to the left in previous post - The Inspector. It’s been a while and a lot of the terminology has been forgotten. Clicking the Inserts tab within the inspector reveals an empty area and right/left clicking within it gives me no option to add an insert fx.

Left clicking is the way.

yeah get nothing when i do :frowning:

If all else fails, try “trashing your prefs” …

https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/safe-start-mode-resetting-the-cubase-preferences.html

Despite advice to the contrary I think you have an installation corruption…these areas should not be blank.

First try trashing prefs…if that doesn’t help (which I don’t think it will) completely uninstall and reinstall.

Cheers Scab and Grim.
Tried the preferences but no joy. Ill try reinstalling and see where that gets me.
Ta
Jim

Ok reinstalled 7.04 then updated to 7.07 and everything is as it should be :slight_smile: so yep as suspected a corrupted install. Thanks to all three of you for you time <- happy chappy .

Cheers
Jim